请调整顺序表的数据,使得左边为奇数,右边为偶数,要求时间复杂度为O(n)。【样例输入】25 34 57 50 16 48 9 62 0【样例输出】25 9 57 50 16 48 34 62

请调整顺序表的数据,使得左边为奇数,右边为偶数,要求时间复杂度为O(n)。

【样例输入】25 34 57 50 16 48 9 62 0

【样例输出】25 9 57 50 16 48 34 62

【注意】0代表输入的结束

#include<stdio.h>
#define MAXSIZE 100
typedef int Elemtype;
typedef struct
{
    Elemtype elem[MAXSIZE];
    int last;
}Seqlist;
void init(Seqlist*L)
{
    L->last=-1;
}
void Adjust(Seqlist*L)
{
    int leftPosition=0,rightPosition=L->last;
    int a,b;
    while(leftPosition<rightPosition)
    {
        a=L->elem[leftPosition];
        b=L->elem[rightPosition];
        if(a%2==1) leftPosition++;
        else if(b%2==0) rightPosition--;
             else{
                L->elem[leftPosition]=b;
                L->elem[rightPosition]=a;
                leftPosition++;
                rightPosition--;
                }

    }
}
void Input(Seqlist*L)
{
    int c;
    int flag=1;
    while(flag)
    {
        scanf("%d",&c);
        if(c!=0)
        {
            L->elem[++L->last]=c;
        }
        else
            flag=0;
    }
}
void showL(Seqlist*L)
{
    int i;
    for(i=0;i<=L->last;i++)
        printf("%d ",L->elem[i]);
}
int main()
{
    Seqlist L;
    init(&L);
    Input(&L);
    Adjust(&L);
    showL(&L);

}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值