Dinner

题目描述

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

输入

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

输出

For each test of the input, output all the name of tableware.

样例输入

3 basketball fork chopsticks

2 bowl letter

样例输出

fork chopsticks

bowl

提示

The tableware only contains: bowl, knife, fork and chopsticks.

#include<stdio.h>
#include<string.h>
char x[1000][1000],y[1000][1000];
char a[100]="bowl",b[100]="knife",c[100]="fork",d[100]="chopsticks";
int main() {
    int n,i,j,p;
    while(scanf("%d",&n)!=EOF) {
        j=1;
        p=0;
        for (i = 1; i <= n; i++) {
            scanf("%s",x[i]);
            if(strcmp(x[i],a)==0 || strcmp(x[i],b)==0 || strcmp(x[i],c)==0 || strcmp(x[i],d)==0) {
                strcpy(y[j],x[i]);
                j++;
                p++;
            }
        }
        for (i = 1; i <= p; i++) {
            for (j = 0; y[i][j] != '\0'; j++) {
                printf("%c",y[i][j]);
            }
                
            printf(" ");
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

*OASIS*

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值