tzoj 5103: Electric Fence

描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20

题意

求出(0,0),(n,m),(p,0)这三个点连成的三角形内有多少个点,不包括边界

题解

分三种情况讨论

当p>m时

算出这个长方形中有多少个点(包括边界)再减去所有边上的点再除以2即是答案

当p=m时

 可以直接得出答案

当p<m时

 与第一种情况类似,只需算出两个三角形内的点数再相减即可

当然也有更快的方法,使用皮克定理:格点多边形面积 = 多边形里的点数+边上的点数/2-1得出

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
typedef pair<double,double> PDD;
typedef unsigned long long ULL;
mt19937 rnd(random_device{}());
uniform_int_distribution<int> dist(0,INT_MAX);   

int gcd(int a,int b)
{
    if(b==0) return a;
    return gcd(b,a%b);
}

int main()
{
    int n,m,p;
    cin>>n>>m>>p;
    int ans;
    if(p>n)
    {
        ans = (p+1)*(m+1);
        ans = ans-2*(p+1)-3*(m-1);
        ans = ans-(gcd(n,m)-1)-(gcd(p-n,m)-1);
        ans /= 2;
        ans += m-1;
    }
    else if(p<n)
    {
        int t = (m+1)*(n-p+1);
        t = t-2*(m+1)-2*(n-p-1)-(gcd(n-p,m)-1);
        t /= 2;
        ans = (m+1)*(n+1);
        ans = ans-2*(m+1)-2*(n-1)-(gcd(n,m)-1);
        ans /= 2;
        ans -= t;
        ans -= (gcd(n-p,m)-1);
    }
    else 
    {
        ans = (m+1)*(n+1);
        ans = ans-2*(m+1)-2*(n-1)-(gcd(n,m)-1);
        ans /= 2;
    }
    cout<<ans;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值