TZOJ 5103: Electric Fence

题目

描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20

题目大意

求由点(n,m),(0,p),(0,0)构成的三角形内部的格点数量。

思路与算法

利用皮克定理2s=2a+b-2(a为三角形内部格点,b为三角形边上的格点,s为三角形面积),由三角形面积和边上的格点求出内部格点。

(1)三角形面积s为x1*y2-x1*y3+x2*y3-x2*y1+x3*y1-x2*y2

(2)边上的格点数b为gcd(线段的铅锤高,水平宽)+1

代码

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
double sum(int x1,int y1,int x2,int y2,int x3,int y3){
    return x1*y2-x1*y3+x2*y3-x2*y1+x3*y1-x2*y2;
}
int gcd(int a,int b){
    if(b==0)
        return a;
    return gcd(b,a%b);
}
int main(){
    int n,m,p;
    cin>>n>>m>>p;
    double s=sum(n,m,0,0,p,0)/2;
    int a,b1,b2;
    if(n!=0)
        b1= gcd(n,m)-1;    //边上除了端点外的格点数量
    else    //n=0特判
        b1=m-1;
    if(n!=p)
        b2= gcd(abs(n-p),m)-1;    //边上除了端点外的格点数量
    else    //n=p特判
        b2=m-1;
    a=s-(b1+b2+p+2)/2+1;
    cout<<a<<endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值