求链表最小值

求链表最小值

Description

请使用递归的方法,求出int链表中最小值。

Input

第1行1个整数,表示链表中元素个数N。

第2行N个整数,为链表中元素值。

Output

1个整数,为链表中最小值。

Sample Input 1 

5
1 2 3 4 5

Sample Output 1

 1

#include <iostream>
using namespace std;
struct ListNode {
    int val;
    ListNode* next;
    ListNode(int x) : val(x), next(nullptr) {}
};
int findMin(ListNode* head)
{
    if (head == nullptr) {
        return 32767;//INT_MAX
    }
    int restMin = findMin(head->next);//一层层遍历下去,直到最后一个指针
    //比较的是递归返回的过程中 restMin和当前结点所存储的head->val的值
    //如果restMin>head->val,也就是递归上来的值大,那么就返回当前结点的值
    //反之亦然
    if (head->val < restMin) //比较当前节点值和剩余部分的最小值
    {
        return head->val;
    } else {
        return restMin;
    }
}
int main() {
    int N;
    cin >> N;
    ListNode* head = nullptr;
    ListNode* current = nullptr;
    for (int i = 0; i < N; ++i)
    {
        int val;
        cin >> val;
        if (head == nullptr) //头结点
        {
            head = new ListNode(val);
            current = head;
        }
        else //非头结点存放
        {
            current->next = new ListNode(val);
            current = current->next;
        }
    }
    cout << findMin(head) << endl;
    while (head != nullptr) //释放内存空间
    {
        ListNode* temp = head;
        head = head->next;
        delete temp;
    }
    return 0;
}
 
     
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值