1003 Emergency

文章描述了一个关于城市紧急救援的问题,其中涉及到使用Dijkstra算法寻找两点间的最短路径,并在路径上最大化收集救援队伍。给定城市数量、道路信息及起点和终点,程序需计算最短路径数量和能聚集的最大救援队数量。解决方案包括构建图并应用Dijkstra算法更新节点的距离、救援队数量信息。
摘要由CSDN通过智能技术生成

1003 Emergency

分数 25

作者 CHEN, Yue

单位 浙江大学

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1​ and C2​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1​, c2​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1​ to C2​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1​ and C2​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题目大意:一共有n座城市,每个城市都部署有救援队,现在已知m条边的起点、终点、路径,以及现在的出发点和目的地,需求出这两点的最短路径的条数,以及最多能得到的救援队的数量

通过dijikstra算法求最短路径,并开两个数组,来分别储存每个点所能得到的最大救援队的数量和最短路径的条数 

#include<bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
int vis[550];
int dis[550];
int side[550][550];
int save[550];
int road[550];
int allsave[550];
int main()
{
	int n,m,c1,c2;
	while(~scanf("%d %d %d %d",&n,&m,&c1,&c2))
	{
		memset(vis,0,sizeof(vis));
		memset(allsave,0,sizeof(allsave));
		memset(road,0,sizeof(road));
		fill(dis,dis+550,INF);
		fill(side[0],side[0]+550*550,INF);
		for(int i=0;i<n;i++)
		scanf("%d",&save[i]);
		for(int i=0;i<m;i++)
		{
			int x,y,z;
			scanf("%d %d %d",&x,&y,&z);
			side[x][y]=z;
			side[y][x]=z;
		}
		allsave[c1]=save[c1];
		dis[c1]=0;
		road[c1]=1;
		for(int i=0;i<n;i++)
		{
			int s=-1;
			int minn=INF;
			for(int j=0;j<n;j++)
			{
				if(!vis[j]&&dis[j]<minn)
				{
					s=j;
					minn=dis[j];
				}
			}
			if(s==-1)
			break;
			vis[s]=1;
			for(int j=0;j<n;j++)
			{
				if(!vis[j]&&side[s][j]!=INF)
				{
					if(dis[s]+side[s][j]<dis[j])
					{
						dis[j]=dis[s]+side[s][j];
						road[j]=road[s];
						allsave[j]=save[j]+allsave[s];
					}
					else if(dis[s]+side[s][j]==dis[j])
					{
						road[j]+=road[s];
						if(allsave[s]+save[j]>allsave[j])
						allsave[j]=allsave[s]+save[j];
					}
				}
			}
		}
		printf("%d %d\n",road[c2],allsave[c2]);
	}
	return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值