静态路由综合实验(IP第一天)

如下图所示,实现题目要求:

1.首先将手画图转换为拓扑图: 

2.对路由器接口配置IP和环回的IP:

R1:

[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 30
[R1-GigabitEthernet0/0/0]int g0/0/1
[R1-GigabitEthernet0/0/1]ip address 192.168.1.9 30
[R1]interface LoopBack 0
[R1-LoopBack0]ip address 192.168.1.33 28
[R1]interface LoopBack 1
[R1-LoopBack1]ip address 192.168.1.49 28


R2:

 

 [R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.1.2 30 
[R2-GigabitEthernet0/0/0]int g0/0/1
[R2-GigabitEthernet0/0/1]ip address 192.168.1.5 30
[R2]interface LoopBack 0    
[R2-LoopBack0]ip address 192.168.1.65 28
[R2]interface LoopBack 1
[R2-LoopBack1]ip address 192.168.1.81 28

 

R3:

[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.1.10 30
[R3-GigabitEthernet0/0/0]int g0/0/1
[R3-GigabitEthernet0/0/1]ip address 192.168.1.13 30
[R3-GigabitEthernet0/0/1]int g0/0/2
[R3-GigabitEthernet0/0/2]ip address 192.168.1.97 27


R4:

 

[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip address 192.168.1.6 30
[R4-GigabitEthernet0/0/0]int g0/0/1
[R4-GigabitEthernet0/0/1]ip address 192.168.1.14 30
[R4-GigabitEthernet0/0/1]int g0/0/2
[R4-GigabitEthernet0/0/2]ip address 192.168.1.17 30
[R4-GigabitEthernet0/0/2]int g4/0/0    
[R4-GigabitEthernet4/0/0]ip address 192.168.1.21 30
[R4]interface LoopBack 0
[R4-LoopBack0]ip address 192.168.1.129 28
[R4]interface LoopBack 1
[R4-LoopBack1]ip address 192.168.1.145 28


R5:

 

[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip address 192.168.1.18 30
[R5-GigabitEthernet0/0/0]int g0/0/1
[R5-GigabitEthernet0/0/1]ip address 12.0.0.1 24
[R5-GigabitEthernet0/0/1]int g0/0/2
[R5-GigabitEthernet0/0/2]ip address 192.168.1.22 30
[R5]interface LoopBack 0
[R5-LoopBack0]ip address 192.168.1.161 28

 

ISP:

<Huawei>sy    
<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.
[Huawei]sy    
[Huawei]sysname ISP
[ISP]inter    
[ISP]interface gi    
[ISP]interface GigabitEthernet 0/0/0
[ISP-GigabitEthernet0/0/0]ip add    
[ISP-GigabitEthernet0/0/0]ip address 12.0.0.2 24
Aug  2 2023 08:57:01-08:00 ISP %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
 on the interface GigabitEthernet0/0/0 has entered the UP state. 
[ISP-GigabitEthernet0/0/0]q
[ISP]inter    
[ISP]interface loo    
[ISP]interface LoopBack 0
[ISP-LoopBack0]ip add    
[ISP-LoopBack0]ip address 1.1.1.1 24

 

3.在R3上配置DHCP,让两台PC可以自动获取IP

[r3]dhcp enable 
Info: The operation may take a few seconds. Please wait for a moment.done.
[r3]ip poo    
[r3]ip pool 1
Info: It's successful to create an IP address pool.
[r3-ip-pool-1]netw    
[r3-ip-pool-1]network 192.168.1.96 mas    
[r3-ip-pool-1]network 192.168.1.96 mask 27
[r3-ip-pool-1]ga    
[r3-ip-pool-1]gateway-list 192.168.1.97
[r3-ip-pool-1]inter    
[r3-ip-pool-1]q
[r3]inter    
[r3]interface gi    
[r3]interface GigabitEthernet 0/0/2
[r3-GigabitEthernet0/0/2]dhc    
[r3-GigabitEthernet0/0/2]dhcp sel    
[r3-GigabitEthernet0/0/2]dhcp select glo    
[r3-GigabitEthernet0/0/2]dhcp select global 

 

4.给路由器配置静态和缺省:

R1:

[R1]ip route-static 192.168.1.64 27 192.168.1.2
[R1]ip route-static 192.168.1.128 27 192.168.1.2
[R1]ip route-static 192.168.1.160 27 192.168.1.2
[R1]ip route-static 192.168.1.128 27 192.168.1.10
[R1]ip route-static 192.168.1.160 27 192.168.1.10
[R1]ip route-static 192.168.1.96 27 192.168.1.10
[R1]ip route-static 192.168.1.0 30 192.168.1.2
[R1]ip route-static 192.168.1.4 30 192.168.1.2
[R1]ip route-static 192.168.1.16 30 192.168.1.2
[R1]ip route-static 192.168.1.20 30 192.168.1.2
[R1]ip route-static 192.168.1.8 30 192.168.1.10
[R1]ip route-static 192.168.1.12 30 192.168.1.10
[R1]ip route-static 192.168.1.16 30 192.168.1.10
[R1]ip route-static 192.168.1.20 30 192.168.1.10
[R1]ip route-static 0.0.0.0 0 192.168.1.2
[R1]ip route-static 0.0.0.0 0 192.168.1.10
R2:

[R2]ip route-static 192.168.1.32 27 192.168.1.1
[R2]ip route-static 192.168.1.96 27 192.168.1.1
[R2]ip route-static 192.168.1.0 30 192.168.1.1
[R2]ip route-static 192.168.1.8 30 192.168.1.1
[R2]ip route-static 192.168.1.4 30 192.168.1.6
[R2]ip route-static 192.168.1.12 30 192.168.1.6
[R2]ip route-static 192.168.1.16 30 192.168.1.6
[R2]ip route-static 192.168.1.20 30 192.168.1.6
[R2]ip route-static 192.168.1.128 27 192.168.1.6
[R2]ip route-static 192.168.1.160 27 192.168.1.6
[R2]ip route-static 0.0.0.0 0 192.168.1.6
R3:

[R3]ip route-static 192.168.1.32 27 192.168.1.9
[R3]ip route-static 192.168.1.64 27 192.168.1.9
[R3]ip route-static 192.168.1.64 27 192.168.1.14
[R3]ip route-static 192.168.1.128 27 192.168.1.14
[R3]ip route-static 192.168.1.160 27 192.168.1.14
[R3]ip route-static 192.168.1.8 30 192.168.1.9
[R3]ip route-static 192.168.1.0 30 192.168.1.9
[R3]ip route-static 192.168.1.4 30 192.168.1.14
[R3]ip route-static 192.168.1.12 30 192.168.1.14
[R3]ip route-static 192.168.1.16 30 192.168.1.14
[R3]ip route-static 192.168.1.20 30 192.168.1.14
[R3]ip route-static 0.0.0.0 0 192.168.1.14

R4:

[R4]ip route-static 192.168.1.32 27 192.168.1.5
[R4]ip route-static 192.168.1.32 27 192.168.1.13
[R4]ip route-static 192.168.1.64 27 192.168.1.5
[R4]ip route-static 192.168.1.96 27 192.168.1.13
[R4]ip route-static 192.168.1.0 30 192.168.1.5
[R4]ip route-static 192.168.1.4 30 192.168.1.5
[R4]ip route-static 192.168.1.8 30 192.168.1.13
[R4]ip route-static 192.168.1.12 30 192.168.1.13
[R4]ip route-static 192.168.1.160 27 192.168.1.18
[R4]ip route-static 192.168.1.160 27 192.168.1.22
[R4]ip route-static 0.0.0.0 0 192.168.1.18
[R4]ip route-static 0.0.0.0 0 192.168.1.22
R5:

[R5]ip route-static 192.168.1.128 27 192.168.1.17
[R5]ip route-static 192.168.1.128 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.64 27 192.168.1.17
[R5]ip route-static 192.168.1.64 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.32 27 192.168.1.17    
[R5]ip route-static 192.168.1.32 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.96 27 192.168.1.17
[R5]ip route-static 192.168.1.96 27 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.4 30 192.168.1.17    
[R5]ip route-static 192.168.1.4 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.0 30 192.168.1.17
[R5]ip route-static 192.168.1.0 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.12 30 192.168.1.17
[R5]ip route-static 192.168.1.12 30 192.168.1.21 preference 61
[R5]ip route-static 192.168.1.8 30 192.168.1.17    
[R5]ip route-static 192.168.1.8 30 192.168.1.21 preference 61

[r5]ip route-static 0.0.0.0 0 12.0.0.2

5.给路由器配置空接口防止成环

[R1]ip route-static 192.168.1.32 27 NULL 0
[R2]ip route-static 192.168.1.64 27 NULL 0
[R3]ip route-static 192.168.1.96 27 NULL 0
[R4]ip route-static 192.168.1.128 27 NULL 0
[R5]ip route-static 192.168.1.160 27 NULL 0
6.在R1里面配置远程登录,基于TCP的23号端口号进行访问

[R1]aaa
[R1-aaa]local-user gyh password cipher 123456
[R1-aaa]local-user gyh service-type telnet
[R1-aaa]local-user gyh privilege level 15
[R1-aaa]q
[R1]user-interface vty 0 4
[R1-ui-vty0-4]authentication-mode aaa

7.R5中配置nat转换以及端口映射

[r5]interface g    
[r5]interface GigabitEthernet  0/0/2
[r5-GigabitEthernet0/0/2]dis    
[r5-GigabitEthernet0/0/2]display this    
[r5-GigabitEthernet0/0/2]display this 
[V200R003C00]
#
interface GigabitEthernet0/0/2
 ip address 12.0.0.1 255.255.255.0 
 nat server protocol tcp global current-interface telnet inside 192.168.1.1 teln
et
 nat outbound 2000
#
8.测试

<ISP>tel    
<ISP>telnet 12.0.0.1
  Press CTRL_] to quit telnet mode
  Trying 12.0.0.1 ...
  Connected to 12.0.0.1 ...

Login authentication


Username:gyh
Password:
  ----------------------------------------------------------------------------- 
    
  User last login information:     
  -----------------------------------------------------------------------------
  Access Type: Telnet      
  IP-Address : 12.0.0.2     
  Time       : 2023-08-02 10:13:00-08:00     
  -----------------------------------------------------------------------------
<r1>

每个路由器ping通ISP环回:

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值