HDU 1232 畅通工程

<div><h1 style="COLOR: #1a5cc8">畅通工程</h1><span size="+0" style=""><strong><span style="font-size: 12px; font-family: Arial; color: green;">Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37759    Accepted Submission(s): 19999
</span></strong></span>

<div class="panel_title" align="left">Problem Description</div><div class="panel_content">某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路? 
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Input</div><div class="panel_content">测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。 
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Output</div><div class="panel_content">对每个测试用例,在1行里输出最少还需要建设的道路数目。 
</div><div class="panel_bottom"> </div>
<div class="panel_title" align="left">Sample Input</div><div class="panel_content"><pre><div style="FONT-FAMILY: Courier New,Courier,monospace">4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0</div>
 

Sample Output
  
  
1 0 2 998
Hint
Hint
Huge input, scanf is recommended.




 
 
</pre><pre name="code" class="objc">
#include<stdio.h>
int root[1005];
int t[1005];        
int find(int x)
{
    int i=x; 
    while(i!=root[i])
        i=root[i];
    int j=x;
    while(j!=root[j])
    {
        root[j]=i;
        j=root[j];
    }
    return i;
    
}

void com(int x,int y,int *num)
{
    int p1,p2;
    p1=find(x);
    p2=find(y);
    if(p1!=p2)
    {    
        root[p1]=p2;
        (*num)--;
    }
}
int main()
{
    int num,p1,p2,m,n,i;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) return 0;
        for(i=1;i<=n;i++)
            root[i]=i;
        num=n-1;
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d %d",&p1,&p2);
            com(p1,p2,&num);
        }
        printf("%d\n",num);
        
    }
    return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值