1002 A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

#include <iostream>
using namespace std;
int main()
{
	int n,flag,test,i=0,sum,j;
	int ia,ib;
	char a[1001]="0";
	char b[1001]="0";
	char c[1001]="0";
	char d[1001]="0";
	test=0;
	while (test<1001)
	{
		a[test]=0;
		b[test]=0;
		c[test]=0;
		d[test]=0;
		++test;
	}
	cin>>n;
	while (i<n)
	{
		cin>>c>>d;
		cout<<"Case "<<i+1<<":"<<endl;
		cout<<c<<" + "<<d<<" = ";
		ia=ib=1000;
		j=1000;
		while (j>=0)
		{
			if (c[j]!=0)
			{
				a[ia]=c[j];
				--ia;
			}
			if (d[j]!=0)
			{
				b[ib]=d[j];
				--ib;
			}
			--j;
		}
		j=0;
		while (j<1001)
		{
			c[j]=0;
			++j;
		}
		--j;
		flag=0;
		while (j>=0)
		{
			sum=a[j]+b[j]+flag;
			if (sum==1)
			{
				c[j]=49;
				flag=0;
			}
			else if (sum==58)
			{
				c[j]=48;
				flag=1;
			}
			else if (sum>105)
			{
				c[j]=sum-58;
				flag=1;
			}
			else if (sum>95)
			{
				c[j]=sum-48;
				flag=0;
			}
			else if (sum>47)
			{
				c[j]=sum;
				flag=0;
			}
			--j;
		}

		++i;
		
		test=0;
		while (test<1001)
		{
			if (c[test]!=0)
				cout<<c[test];
			++test;
		}
		if (i<n)
		{
			test=0;
			while (test<1001)
			{
				a[test]=0;
				b[test]=0;
				c[test]=0;
				d[test]=0;
				++test;
			}
			cout<<endl<<endl;
		}
	}
	cout<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值