poj 1651 Multiplication Puzzle(区间dp)

题目链接

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6612 Accepted: 4029

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

题意:排成一排的n个数字a1,a2...an,每次选择删除一个数字(不能删第1个和最后一个),假设删除的数字为ai,则花费为ai*a(i-1)*a(i+1),删除该数字以后剩下的数字又合并成一个新的数列,问最后删到只剩两个数字的最小花费。

题解:如果正向的思考,最先删除某个数字,再删除第二个数字,等。那么很难处理数列合并的问题。但是如果我们逆向的思考,最后删除某个数字,那么问题可以用动态规划解决。设问题为将一个数列变到目标状态的最小花费,那么原问题就是将下标为1到n的数列,变到目标状态的最小花费。假设我们最后一个删除的数字为下标为i的数字,那么问题就转换为求(子问题:下标为1到i的数列,变到目标状态的最小花费)+(子问题:下标为i到n的数列,变到目标状态的最小花费)+ai*a1*an。

所以我们可以这样定义状态,用dp[i][j] 表示将下标为i到j这段连续的数列变到目标状态的最小花费。转移就是:

dp[i][j]=min(dp[i][k]+dp[k][j]+ak*ai*aj),i<k<j。

详情见代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define nn 110
#define inff 0x3fffffff
using namespace std;
int dp[110][110];
int n;
int a[nn];
int dfs(int l,int r)
{
    if(dp[l][r]!=-1)
        return dp[l][r];
    if(l==r-1)
        return 0;
    dp[l][r]=inff;
    for(int i=l+1;i<r;i++)
    {
        dp[l][r]=min(dp[l][r],a[i]*a[l]*a[r]+dfs(l,i)+dfs(i,r));
    }
    return dp[l][r];
}
int main()
{
    int i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        memset(dp,-1,sizeof(dp));
        printf("%d\n",dfs(1,n));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值