poj 3661 Running(dp)

题目链接

Running
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5279 Accepted: 1966

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

题意:跑步,有n分钟可以跑,第i分钟跑的距离为Di。每一分钟可以选择跑与不跑。跑的话疲劳程度+1,疲劳程度初始时为0,不能超过m。不跑的话每分钟疲劳-1,但是要直到疲劳程度减少为0,才可以再跑。n分钟跑完后,疲劳程度必须为0。问最多能跑多少距离?

题解:动态规划问题。用dp[i][j][0,1] 表示第i分钟,疲劳程度为j,0,1表示这分钟跑与没跑,该状态下跑的最远距离。

详情见代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define nn 11000
#define inff 0x3fffffff
using namespace std;
int n,m;
int d[nn];
int dp[nn][510][2];
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d",&d[i]);
        }
        for(i=0;i<=n;i++)
        {
            for(j=0;j<=m;j++)
                dp[i][j][0]=dp[i][j][1]=-inff;
        }
        dp[0][0][1]=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<=m;j++)
            {
                if(dp[i][j][1]>=0)
                {
                    if(j+1==m)
                        dp[i+1][m][0]=max(dp[i+1][m][0],dp[i][j][1]+d[i+1]);
                    else
                        dp[i+1][j+1][1]=max(dp[i+1][j+1][1],dp[i][j][1]+d[i+1]);
                    if(j>1)
                        dp[i+1][j-1][0]=max(dp[i+1][j-1][0],dp[i][j][1]);
                    else
                        dp[i+1][0][1]=max(dp[i+1][0][1],dp[i][j][1]);
                }
                if(dp[i][j][0]>=0)
                {
                    if(j>1)
                        dp[i+1][j-1][0]=max(dp[i+1][j-1][0],dp[i][j][0]);
                    else
                        dp[i+1][0][1]=max(dp[i+1][0][1],dp[i][j][0]);
                }
            }
        }
        printf("%d\n",dp[n][0][1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值