Closest Common Ancestors
Time Limit: 2000MS | Memory Limit: 10000K | |
Total Submissions: 13821 | Accepted: 4483 |
Description
Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)
Input
The data set, which is read from a the std input, starts with the tree description, in the form:
nr_of_vertices
vertex:(nr_of_successors) successor1 successor2 ... successorn
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:
nr_of_pairs
(u v) (x y) ...
The input file contents several data sets (at least one).
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.
nr_of_vertices
vertex:(nr_of_successors) successor1 successor2 ... successorn
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:
nr_of_pairs
(u v) (x y) ...
The input file contents several data sets (at least one).
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.
Output
For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times
For example, for the following tree:
For example, for the following tree:
Sample Input
5 5:(3) 1 4 2 1:(0) 4:(0) 2:(1) 3 3:(0) 6 (1 5) (1 4) (4 2) (2 3) (1 3) (4 3)
Sample Output
2:1 5:5
Hint
Huge input, scanf is recommended.
Source
离线LCA的tarjan算法,上班的时候顿悟了,然后回来敲一敲过了,话说真的满巧妙的,抓住了后序遍历根节点是最后遍历到的性质。
恶心的在于输入……
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
struct Query
{
int idx,ans;
};
vector<int> edge[1005];
int pnt[1005];
int lca[1005][1005];
int ans[1005];
int n;
int vis[1005];
int Find(int t)
{
// printf("%d~~~!%d\n",t,pnt[t]);
if (pnt[t]==t) return t;
pnt[t]=Find(pnt[t]);
return pnt[t];
}
void DFS(int t,int p)
{
int i,x;
for (i=0;i<edge[t].size();i++)
{
x=edge[t][i];
DFS(x,t);
}
for (i=0;i<n;i++)
{
if (i==t) continue;
if (Find(i)==i) continue;
lca[i][t]=lca[t][i]=Find(i);
}
pnt[t]=p;
}
int Root()
{
int i;
for (i=0;i<n;i++)
{
if (vis[i]==0) return i;
}
}
int main()
{
int i,j,y,x,m;
while(scanf("%d",&n)!=EOF)
{
memset(vis,0,sizeof(vis));
for (i=0;i<n;i++)
{
pnt[i]=i;
edge[i].clear();
}
for (i=0;i<n;i++)
{
scanf("%d:(%d)",&x,&m);
while(m--)
{
scanf("%d",&y);
vis[y-1]=1;
edge[x-1].push_back(y-1);
}
}
DFS(Root(),-1);
for (i=0;i<n;i++)
{
lca[i][i]=i;
}
scanf("%d",&m);
memset(ans,0,sizeof(ans));
while(m--)
{
while(getchar()!='(');
scanf("%d %d",&x,&y);
ans[lca[x-1][y-1]]++;
while(getchar()!=')');
}
for (i=0;i<n;i++)
{
if (ans[i]!=0) printf("%d:%d\n",i+1,ans[i]);
}
}
return 0;
}