poj 2441 Arrange the Bulls

Description

Farmer Johnson's Bulls love playing basketball very much. But none of them would like to play basketball with the other bulls because they believe that the others are all very weak. Farmer Johnson has N cows (we number the cows from 1 to N) and M barns (we number the barns from 1 to M), which is his bulls' basketball fields. However, his bulls are all very captious, they only like to play in some specific barns, and don’t want to share a barn with the others.

So it is difficult for Farmer Johnson to arrange his bulls, he wants you to help him. Of course, find one solution is easy, but your task is to find how many solutions there are.

You should know that a solution is a situation that every bull can play basketball in a barn he likes and no two bulls share a barn.

To make the problem a little easy, it is assumed that the number of solutions will not exceed 10000000.

Input

In the first line of input contains two integers N and M (1 <= N <= 20, 1 <= M <= 20). Then come N lines. The i-th line first contains an integer P (1 <= P <= M) referring to the number of barns cow i likes to play in. Then follow P integers, which give the number of there P barns.

Output

Print a single integer in a line, which is the number of solutions.

Sample Input

3 4
2 1 4
2 1 3
2 2 4

Sample Output

4

Source


显然状态dp

题意很简单,n头牛,m个位置,每头牛有各自喜欢的位置,问安排这n头牛使得每头牛都在各自喜欢的位置有几种安排方法。

直接开二维数组MLE,改成滚动数组4000ms时限3954ms灰过……

后来一想,不要滚动数组,状态循环从大到小计算就可以了,结果125ms……

代码

#include <stdio.h>
#include <string.h>

int map[25][25];
int now[(1<<20)+5];

int main()
{
    int i,j,n,m,k,x,p,ret;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(map,0,sizeof(map));
        for (i=0;i<n;i++)
        {
            scanf("%d",&k);
            while(k--)
            {
                scanf("%d",&x);
                x--;
                map[i+1][x]=1;
            }
        }
        if (n>m)
        {
            printf("0\n");
            continue;
        }
        memset(now,0,sizeof(now));
        now[0]=1;
        for (i=0;i<n;i++)
        {
            for (j=(1<<m)-1;j>=0;j--)
            {
                if (now[j]==0) continue;
                for (k=0;k<m;k++)
                {
                    if ((j & (1<<k))!=0) continue;
                    if (map[i+1][k]==0) continue;
                    p=(j | (1<<k));
                    now[p]+=now[j];
                }
                now[j]=0;
            }
        }
        ret=0;
        for (i=0;i<(1<<m);i++)
        {
            ret+=now[i];
        }
        printf("%d\n",ret);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值