hdu3555 Bomb

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1604    Accepted Submission(s): 592


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong


顺便写道数位dp的题,直接dfs下去就可以了,没什么说的。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int dig[20];
long long dp[20][2][12];

long long F(int pos,bool have,int last,bool inf)
{
    int i;
    if (pos==-1) return have;
    if (!inf && dp[pos][have][last]!=-1) return dp[pos][have][last];
    int end=inf?dig[pos]:9;
    long long ans=0;
    for (i=0;i<=end;i++)
    {
        if (last==4 && i==9) ans+=F(pos-1,true,i,inf && (i==end));
        else ans+=F(pos-1,have,i,inf && (i==end));
    }
    if (!inf)
    {
        dp[pos][have][last]=ans;
    }
    return ans;
}

long long Cal(long long t)
{
    int i,j,pos=0;
    while(t)
    {
        dig[pos++]=t%10;
        t/=10;
    }
    return F(pos-1,0,0,1);

}

int main()
{
    int i,j,T;
    __int64 n;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,-1,sizeof(dp));
        scanf("%I64d",&n);
        printf("%I64d\n",Cal(n));
    }
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值