hdu1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3796    Accepted Submission(s): 2309


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L




线段树求逆序数。

维护一个线段树,(0~n-1),然后每一段维护的是该段已经出现过了几个数字,然后每次按输入顺序插入数字,然后统计该数字之前出现了几个比他小的数字,之后把该数字插入。

关于求起始点为k的逆序数,假设s为起始点为k-1的逆序数,第k位的数字为a[k],那么讲第k位数字移到最后去,其他位增加的逆序数应该为比他大的个数,即n-a[k]-1,然后需要减少掉他在最前面所导致的逆序数个数,即比他小的数,为a[k],所以这么递推就可以了。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef struct
{
    int l,r,num;
}Tree;


Tree tree[50005];
int a[5005];
int num[5005];

void Build(int t,int l,int r)
{
    int mid;
    tree[t].l=l;
    tree[t].r=r;
    tree[t].num=0;
    if (l==r) return;
    mid=(l+r)/2;
    Build(2*t+1,l,mid);
    Build(2*t+2,mid+1,r);
}

int Find(int t,int x,int y)
{
    int mid,l,r,ans;
    l=tree[t].l;
    r=tree[t].r;
    if (l==x && r==y) return tree[t].num;
    mid=(l+r)/2;
    ans=0;
    if (x<=mid) ans+=Find(2*t+1,x,min(y,mid));
    if (y>mid) ans+=Find(2*t+2,max(x,mid+1),y);
    return ans;
}

void Add(int t,int x)
{
    int l,r,mid;
    l=tree[t].l;
    r=tree[t].r;
    tree[t].num++;
    if (l==r) return;
    mid=(l+r)/2;
    if (x<=mid) Add(2*t+1,x);
    if (x>mid) Add(2*t+2,x);
}

int main()
{
    int i,j,n,ans,s;
    while(scanf("%d",&n)!=EOF)
    {
        Build(0,0,n-1);
        for (i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            num[i]=Find(0,0,a[i]);
            Add(0,a[i]);
        }
        ans=0;
        for (i=0;i<n;i++)
        {
            ans+=num[i];
        }
        ans=n*(n-1)/2-ans;
        s=ans;
        for (i=0;i<n;i++)
        {
            s=s+(n-a[i]-1)-a[i];
            ans=min(ans,s);
        }
        printf("%d\n",ans);
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值