1015. Reversible Primes

Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意

给定一个十进制正整数n和进制数d,判断n是否为素数,以及将n转换为d进制逆序后再转换为十进制得到的数是否为素数。

思路

首先判断n本身是否为素数(注意排除 n = 1 这种特殊情况),再转换为d进制逆序求十进制,在求d进制过程中可以直接对顺序得到的余数进行处理(相当于逆序)。


代码实现

#include <cstdio>
#include <cmath>

bool isPrime(int n)
{
    if (n == 1)     // 特殊情况排除
        return false;
    
    for (int i = 2; i <= sqrt(n); i++)
        if (n % i == 0)
            return false;
            
    return true;
}

bool judgeReverse(int n, int radix)
{
    int re = 0;     // 存储转换后的十进制数
    int r;          // 余数

    if (!isPrime(n))
        return false;
    
    while (n != 0)
    {
        r = n % radix;
        re = re * radix + r;    // 最先得到的余数即是逆序后的d进制的第一位
        n /= radix;
    }

    if (isPrime(re))
        return true;
    else
        return false;
}

int main()
{
    int n, d;

    while(scanf("%d", &n), n >= 0)
    {
        scanf("%d", &d);
        if (judgeReverse(n, d))
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值