hdu 1165(找规律)

82 篇文章 0 订阅
78 篇文章 0 订阅

Problem Description
As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.

Ackermann function can be defined recursively as follows:


Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).
 

Input
Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24. 
Input is terminated by end of file.
 

Output
For each value of m,n, print out the value of A(m,n).
 

Sample Input
  
  
1 3 2 4
 

Sample Output
  
  
5 11


dp记忆化搜索遇到麻烦时需要适当考虑是否是方法选择问题,刚开始用记忆化搜索写的,怎么都栈溢出,百度一下原来这题只能找规律去求解(当编程技巧达到一定程度会忘掉一些最基本的解题方法,当初啥都不会时这种题只能去找规律的,反而学的多了这些基本方法反而容易被丢弃!!)谨以此题警告自己:当一种看似对的方法错了时,得马上想想别的方法转移思路,否则挂死在一棵树上就悲剧了!


#include<iostream>  
using namespace std;  
const int maxn=1001111;  
int dp[4][maxn];  
int x,y;  
void dpstart()  
{  
    memset(dp,0,sizeof(dp));  
    for(int i=0;i<=1000111;i++)  
    {  
        dp[0][i]=i+1;      
    }  
    dp[1][0]=dp[0][1];  
    for(int i=1;i<=1000111;i++)  
    {  
        dp[1][i]=dp[0][dp[1][i-1]];     
    }  
    dp[2][0]=dp[1][1];  
    for(int i=1;i<=1000111;i++)  
    {  
        dp[2][i]=dp[1][dp[2][i-1]];      
    }  
    dp[3][0]=dp[2][1];  
    for(int i=1;i<=24;i++)  
    {  
        dp[3][i]=2*dp[3][i-1]+3;  
    }  
    return ;      
}  
int main()  
{  
    dpstart();  
    while(cin>>x>>y)  
    {  
        cout<<dp[x][y]<<endl;      
    }     
    return 0;  
}  






  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值