bzoj1646 [Usaco2007 Open]Catch That Cow 抓住那只牛

6 篇文章 0 订阅
3 篇文章 0 订阅
农夫约翰从点N出发,目标是点K处的逃牛。约翰能步行或瞬移。步行可在1分钟内到达相邻点,瞬移可1分钟内到达原点的两倍位置。奶牛静止不动。求约翰抓住牛的最短时间。
摘要由CSDN通过智能技术生成

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 <= N <= 100,000) on a number line and the cow is at a point K (0 <= K <= 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X-1 or X+1 in a single minute * Teleporting: FJ can move from any point X to the point 2*X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

农夫约翰被通知,他的一只奶牛逃逸了!所以他决定,马上幽发,尽快把那只奶牛抓回来.他们都站在数轴上.约翰在N(O≤N≤100000)处,奶牛在K(O≤K≤100000)处.约翰有两种办法移动,步行和瞬移:步行每秒种可以让约翰从z处走到x+l或x-l处;而瞬移则可让他在1秒内从x处消失,在2x处出现.然而那只逃逸的奶牛,悲剧地没有发现自己的处境多么糟糕,正站在那儿一动不动.那么,约翰需要多少时间抓住那只牛呢?

Input

  • Line 1: Two space-separated integers: N and K

    仅有两个整数N和K.

Output

  • Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

    最短的时间.

Sample Input

5 17

Farmer John starts at point 5 and the fugitive cow is at point 17.

Sample Output

4

OUTPUT DETAILS:

The fastest way for Farmer John to reach the fugitive cow is to
move along the following path: 5-10-9-18-17, which takes 4 minutes.

Key To Problem

USACO SILVER的题,按理说还算是比较水的,事实上也是这样,但为什么我在bzoj上AC的代码在poj上交了6遍C++RE!交了2遍G++WA!为什么!
好吧,这是一道bfs的题。

Code

#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 101000
using namespace std;
int n,m;
int t[5];
bool used[N<<1];
int dis[N<<1];

int bfs(int u)
{
    queue<int>Q;
    Q.push(u);
    used[u]=true;
    while(!Q.empty())
    {
        int k=Q.front();
        Q.pop();
        if(k==m) return dis[k];
        t[1]=k+1,t[2]=k-1;
        if(k<m) t[3]=k*2;
        for(int i=1;i<=3;i++)
        {
            if(!used[t[i]])
            {
                used[t[i]]=true;
                dis[t[i]]=dis[k]+1;
                Q.push(t[i]);
            }
        }
    }
}

int main()
{
//  freopen("catchcow.13.in","r",stdin);
//  freopen("catchcow.out","w",stdout);
    cin>>n>>m;
    if(m<=n)
    {
        cout<<n-m<<endl;
        return 0;
    }
    cout<<bfs(n)<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值