vector a;
a.resize()改变vector的大小
题目大意:
输入n,得到编号为0~n-1的木块,分别摆放在顺序排列编号为0~n-1的位置。现对这些木块进行操作,操作分为四种。
1、move a onto b:把木块a、b上的木块放回各自的原位,再把a放到b上;
2、move a over b:把a上的木块放回各自的原位,再把a发到含b的堆上;
3、pile a onto b:把b上的木块放回各自的原位,再把a连同a上的木块移到b上;
4、pile a over b:把a连同a上木块移到含b的堆上。
当输入quit时,结束操作并输出0~n-1的位置上的木块情况
Sample Input
10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit
Sample Output
0: 0
1: 1 9 2 4
2:
3: 3
4:
5: 5 8 7 6
6:
7:
8:
9:
#include<cstdio>
#include<string>
#include<vector>
#include<iostream>
using namespace std;
const int maxn=31;
vector<int> pile[maxn];
int n;
void pileclear(int p,int h) //把某一堆上面所有的木块位置还原。
{
for(int i=h+1;i<pile[p].size();i++)
{
pile[pile[p][i]].push_back(pile[p][i]);
}
pile[p].resize(h+1); //大小收束为h+1,不是h,只是归位上面的木块
}
void putpile(int p1,int h,int p2) //把第一堆放到第二堆上面
{
for(int i=h;i<pile[p1].size();i++)
{
pile[p2].push_back(pile[p1][i]);
}
pile[p1].resize(h); //同时把放到第二堆上面的内容清除
}
void findpile(int a,int &p,int &h) //寻找要查找的元素位置,在哪一堆,高度为多少
{
for(int i=0;i<n;i++)
{
for(int j=0;j<pile[i].size();j++)
{
if(a==pile[i][j])
{
p=i;
h=j;
return;
}
}
}
}
int main()
{
cin>>n;
for(int i=0;i<n;i++)
{
pile[i].push_back(i);
}
string s1,s2;
int a,b,pa,ha,pb,hb;
while(cin>>s1)
{
if(s1=="quit") break;
cin>>a>>s2>>b;
findpile(a,pa,ha);
findpile(b,pb,hb);
if(pa==pb) continue; //非法操作
if(s1=="move") pileclear(pa,ha);
if(s2=="onto") pileclear(pb,hb);
putpile(pa,ha,pb);
}
for(int i=0;i<n;i++)
{
printf("%d:",i);
for(int j=0;j<pile[i].size();j++)
{
printf(" %d",pile[i][j]);
}
printf("\n");
}
return 0;
}