PAT A 2020年冬 7-2 Subsequence in Substring AC代码

7-2 Subsequence in Substring (25 分)

substring is a continuous part of a string. A subsequence is the part of a string that might be continuous or not but the order of the elements is maintained. For example, given the string atpaaabpabttpabt is a substring, while pat is a subsequence.

Now given a string S and a subsequence P, you are supposed to find the shortest substring of S that contains P. If such a solution is not unique, output the left most one.

Input Specification:

Each input file contains one test case which consists of two lines. The first line contains S and the second line P. S is non-empty and consists of no more than 104 lower English letters. P is guaranteed to be a non-empty subsequence of S.

Output Specification:

For each case, print the shortest substring of S that contains P. If such a solution is not unique, output the left most one.

Sample Input:

atpaaabpabttpcat
pat

结尾无空行

Sample Output:

pabt

结尾无空行

AC代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
string S,P;
bool flag1;
int End=-1,Min=1000000000,tag;
void search(int start,int index){
	bool flag=false;
	for(int i=start;i<S.size();i++){
		if(S[i]==P[index]){
			flag=true;
			start=i;
			End=start;
			break;
		}
	}
	if(flag==false){
		flag1=false;
		return;
	}else{
		if(index==P.size()-1) return;
		search(start+1,index+1);
	}
}
int main(){
	cin>>S>>P;
	for(int i=0;i<S.size();i++){
		if(S[i]==P[0]){
			flag1=true;
			search(i+1,1);
			if(flag1&&End-i+1<Min){
				Min=End-i+1;
				tag=i;
			}
		}
	}
	cout<<S.substr(tag,Min);
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值