百练 POJ 1724 roads

描述
N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 
输入
The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.
输出
The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 
样例输入
5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2
样例输出

11

注意 1.邻接表存放。这里相当于二维数组了 i是城市 j是它通向的每一个城市 用结构体存放里面的各种信息

2.剪枝 

最优性剪枝:1.判断当前走过的路加上去下一个要走的会不会已经大于minlen 

2.记录到每个城市最短路的长度 但是还有钱的问题 所以二维数组 记录从1到每个城市(i)所花钱(j)时的最短

路径 记得初始化成很大


#include <iostream>
#include<vector>
#include<stdio.h>
#include<cstring>
using namespace std;
int minlen,totallen,totalcost,k,r,n;
int visited[110];
int midl[110][10010];        //从起点1走到i城花费j钱数的最短路数
struct road
{
    int d,t,l;
};
vector<vector<road> >g(110);            //这得有个空格
void dfs(int s)
{
    if(s==n)
    {
        minlen=min(minlen,totallen);     //全部走完
        return;
    }
    for(int i=0;i<g[s].size();i++)
    {
        road r=g[s][i];
        if(totalcost+r.t>k)continue; //不走下面的 continue的用法是跳过本次循环下面未执行的语句
        if(!visited[r.d])      //???r.d是几呢
        {
            if(totallen+r.l>=minlen)continue;
            if(totallen+r.l>=midl[r.d][r.t+totalcost])continue;
            midl[r.d][r.t+totalcost]=totallen+r.l;
            visited[r.d]=1;
            totallen+=r.l;
            totalcost+=r.t;
            dfs(r.d);
            visited[r.d]=0;   //一种方法完成后要撤销这种走法啊 还可以从别处往这走
            totallen-=r.l;
            totalcost-=r.t;
        }
    }


}
int main()
{


    while(cin>>k>>n>>r)
    {
        for(int i=0;i<r;i++)    //共r条路
        {
            int s;
            road r;
            scanf("%d%d%d%d",&s,&r.d,&r.l,&r.t);
            if(s!=r.d)g[s].push_back(r);   //s代表起点 二维数组 起点 终点不能相同
        }
        memset(visited,0,sizeof(visited));
        totallen=0;
        minlen=1<<30;
        for(int i=0;i<110;i++)           //记得先把他置成大数啊
        {
            for(int j=0;j<10010;j++)
            midl[i][j]=1<<30;
        }
        totalcost=0;
        visited[1]=1;
        dfs(1);
        if(minlen<(1<<30))cout<<minlen<<endl;
        else cout<<"Impossible"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值