树状数组 Ultra-QuickSort 离散化+逆序数

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0
一个数列靠相邻两个交换的方法变成正序 就是求他的逆序数 没想明白为什么
统计逆序数的方法就是query(i) sum+=i-query(i)
query(i)查询到比当前数小的数 i-query(i)就是比当前数大的数
比如
下标 1 2 3 4 5
  值 0 0 0 0 0
插入个5把               这是逆序数为1-query(5)=0 不存在 
下标 1 2 3 4 5 
  值 0 0 0 0 1
插入个2把               这是逆序数为2-query(2)=1 
下标 1 2 3 4 5 
  值 0 1 0 0 1

然而这个题要用离散化 
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=500005;
int a[maxn],c[maxn];
int n;
struct org
{
    int v, f;
}b[maxn];
int cmp(org a,org b)
{
    return a.v<b.v;
}
int lowbit(int i)
{
    return i&(-i);
}
int update(int i,int x)
{
    while(i<=maxn)
    {
        c[i]=c[i]+x;
        i=i+lowbit(i);
    }
    //cout<<"1"<<endl;
}
int query(int i)
{
    int sum=0;
    while(i>0)
{
        sum+=c[i];
        i=i-lowbit(i);

    }

    return sum;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&b[i].v);
            b[i].f=i;
        }
        sort(b+1,b+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            a[b[i].f]=i;
        }
        long long  sum=0;
        for(int i=1;i<=n;i++)
        {
            update(a[i],1);
            sum+=i-query(a[i]);
        }
        cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值