Hdu5671 Matrix 矩阵、行列交换+行列加值

Problem Description
There is a matrix M that has n rows and m columns (1n1000,1m1000) .Then we perform q(1q100,000) operations:
1 x y: Swap row x and row y (1x,yn) ;
2 x y: Swap column x and column y (1x,ym) ;
3 x y: Add y to all elements in row x (1xn,1y10,000) ;
4 x y: Add y to all elements in column x (1xm,1y10,000) ;
Input
There are multiple test cases. The first line of input contains an integer T(1T20) indicating the number of test cases. For each test case:
The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1Mi,j10,000) for all (1in,1jm) .
The following q lines contains three integers a(1a4) , x and y .
Output
For each test case, output the matrix M after all q operations.
Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
Sample Output
  
  
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
Source

对一个矩阵进行行列交换以及加值操作,直接按题所给方式去做必然超时。

但考虑操作都是针对整一行,整一列的,可以考虑用数组去记录操作的行列号,而不是直接移动矩阵元素。

include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long LL;
struct node{
    int s;
    int add;
}row[1005],column[1005];
int a[1005][1005];
int main()
{
    int t,n,m,s,o,x,y;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d%d",&n,&m,&s);
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%d",&a[i][j]);
            }
        }
        for(int i=1;i<=n;i++){
            row[i].add=0;
            row[i].s=i;
        }
        for(int i=1;i<=m;i++){
            column[i].add=0;
            column[i].s=i;
        }
        for(int i=0;i<s;i++){
            scanf("%d%d%d",&o,&x,&y);
            if(o==1){
                swap(row[x],row[y]);
            }else if(o==2){
                swap(column[x],column[y]);
            }else if(o==3){
                row[x].add+=y;
            }else{
                column[x].add+=y;
            }
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                printf(j==1? "%d":" %d",a[row[i].s][column[j].s]+row[i].add+column[j].add);
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值