hdu 3979 Monster【贪心】

Monster

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1741    Accepted Submission(s): 470


Problem Description
One day, v11 encounters a group of monsters in a foreast. In order to defend the homeland, V11 picks up his weapon and fights!

All the monsters attack v11 at the same time. Every enemy has its HP, and attack value ATK. In this problem, v11 has his ATK and infinite HP. The damage (also means reduction for HP) is exactly the ATK the attacker has. For example, if v11's ATK is 13 and the monster's HP is 27, then after v11's attack, the monster's HP become 27 - 13 = 14 and vice versa.

v11 and the monsters attack each other at the same time and they could only attack one time per second. When the monster's HP is less or equal to 0 , we think this monster was killed, and obviously it would not attack any more. For example, v11's ATK is 10 and a monster's HP is 5, v11 attacks and then the monster is killed! However, a monster whose HP is 15 will be killed after v11 attack for two times. v11 will never stop until all the monsters are killed ! He wants to minimum the HP reduction for the fight! Please note that if in some second, some monster will soon be killed , the monster's attack will works too.
 

Input
The first line is one integer T indicates the number of the test cases. (T <=100)

Then for each case, The first line have two integers n (0<n<=10000), m (0<m<=100), indicates the number of the monsters and v11's ATK . The next n lines, each line has two integers hp (0<hp<=20), g(0<g<=1000) ,indicates the monster's HP and ATK.
 

Output
Output one line.

First output “Case #idx: ”, here idx is the case number count from 1. Then output the minimum HP reduction for v11 if he arrange his attack order optimal .
 

Sample Input
  
  
2 3 1 1 10 1 20 1 40 1 10 7 3
 

Sample Output
  
  
Case #1: 110 Case #2: 3
 

Author
v11
 

题目大意:V11是一个无敌的人(打不死),但是他的攻击力有限,每回合怪物和v11同时互相攻击,问最少V11受到的伤害、

解题思路:按照从大到小排序a[i].g/a[i].huihe【这里前边是伤害值,后边是打死这个怪物需要的时间(回合数)】,求出攻击时候单位收益、

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long int
struct monster
{
    int hp;
    int g;
    int huihe;
    double sor;
}a[1212121];
int cmp(monster a,monster b)
{
    return a.sor>b.sor;
}
int main()
{
    int kase=0;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        ll sum=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            int hp,g,num;
            scanf("%d%d",&a[i].hp,&a[i].g);
            if(a[i].hp%m==0)
            a[i].huihe=a[i].hp/m;
            else
            a[i].huihe=a[i].hp/m+1;
            a[i].sor=(double)a[i].g/(double)a[i].huihe;
            sum+=a[i].g;
        }
        sort(a,a+n,cmp);
        ll output=0;
        for(int i=0;i<n;i++)
        {
            output+=sum*a[i].huihe;
            sum-=a[i].g;
        }
        printf("Case #%d: %I64d\n",++kase,output);
    }
}








.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值