组合 | ||||||
| ||||||
Description | ||||||
给出一个正整数N,从集合{1,2,3..N} 中找出所有大小为k的子集, 并按照字典序从小到大输出。 | ||||||
Input | ||||||
第一行是一个整数T,代表T组测试数据。 接下来T行,每行是两个正整数n(1<=n<=10), k(1<=k<=n)。 | ||||||
Output | ||||||
对于每组数据按字典序输出所有符合条件的子集。 | ||||||
Sample Input | ||||||
1 5 3 | ||||||
Sample Output | ||||||
1 2 3 1 2 4 1 2 5 1 3 4 1 3 5 1 4 5 2 3 4 2 3 5 2 4 5 3 4 5 | ||||||
Source | ||||||
2014.11.29新生赛-热身赛 |
因为N并不大,所以我们可以直接暴力做,但是暴力耗时间还是比较多的,而且敲起来比较费劲,所以我们这里dfs来解决这个问题也是一个很好的思路。
难点:字典序从小到大输出,我们不必要来纠结这个问题,在dfs的时候我们只需要从1遍历到n即可。
代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int output[15];
int n,m;
void dfs(int output[],int num)
{
if(num==m)
{
for(int i=0;i<m-1;i++)
{
printf("%d ",output[i]);
}
printf("%d\n",output[m-1]);
return ;
}
if(num==0)
{
for(int i=1;i<=n-m+1;i++)
{
output[num]=i;
dfs(output,num+1);
}
}
if(num>0)
{
for(int i=1;i<=n;i++)
{
if(output[num-1]<i)
{
output[num]=i;
dfs(output,num+1);
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(output,0,sizeof(output));
scanf("%d%d",&n,&m);
dfs(output,0);
}
}