HDU 2141 can you find it?【二分查找】

can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 21501    Accepted Submission(s): 5447


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
 


Sample Output
Case 1:
NO
YES
NO
 




 
 


Author
wangye
 

Source
 

题目大意:给出三个集合A,B,C,给出一个数W,在集合A,B,C中各找到一个元素a,b,c,使得其加和等于W。

三层for时间复杂度较高,我们可以对其优化,我们两层for遍历A,B集合中元素,加和后放在一个数组det【】中。然后我们使用二分查找的方法,对w-c【i】进行查找,如果找到了w-c【i】,那么就输出YES,否则输出NO。

思考过程是在不断TLE中形成的T___T

AC代码:

#include<stdio.h>
#include<string.h>
#include<climits>
#include<algorithm>
using namespace std;
#define ll long long int
ll det[505*505];
ll a[505];
ll b[505];
ll c[505];
int cont;
int erfen(ll x)
{
    int l=0;int r=cont-1;
    while(r-l>=0)
    {
        int mid=(l+r)/2;
        //printf("%d %d %d\n",l,r,mid);
        if(det[mid]>x)
        {
            //printf("yes\n");
            r=mid-1;
        }
        else if(det[mid]<x)
        {
            //printf("yes2\n");
            l=mid+1;
        }
        else
        return 1;
    }
    return 0;
}
int main()
{
    int n1,n2,n3;
    int kase=0;
    while(~scanf("%d%d%d",&n1,&n2,&n3))
    {
        memset(det,0,sizeof(det));
        cont=0;
        for(int i=0;i<n1;i++)scanf("%I64d",&a[i]);
        for(int i=0;i<n2;i++)scanf("%I64d",&b[i]);
        for(int i=0;i<n3;i++)scanf("%I64d",&c[i]);
        for(int i=0;i<n1;i++)
        {
            for(int j=0;j<n2;j++)
            {
                det[cont++]=a[i]+b[j];
            }
        }
        sort(c,c+n3);
        sort(det,det+cont);
        int q;
        scanf("%d",&q);
        printf("Case %d:\n",++kase);
        while(q--)
        {
            ll w;
            scanf("%I64d",&w);
            int ok=0;
            for(int i=0;i<n3;i++)
            {
                if(erfen((ll)w-c[i])==1)
                {
                    ok=1;
                    printf("YES\n");
                    break;
                }
            }
            if(ok==0)printf("NO\n");
        }
    }
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值