ZOJ Light Bulb 3203【思维】

Light Bulb

Time Limit: 1 Second       Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input
3
2 1 0.5
2 0.5 3
4 3 4
Sample Output
1.000
0.750
4.000


Author:  GUAN, Yao
Source:  The 6th Zhejiang Provincial Collegiate Programming Contest


题目大意:给你图中标明的H,h,D,h随意走动,求最大的L的长度。

思路:枚举+推导公式

思路:

首先求出两个相对值,一个是没有射在墙上的影子,一个是整个h的长度就是影子的长度。

然后我们枚举i来求在地上和墙上都有影子的情况。

对于这部分有图:


根据图片中给出的数据不难得出:

H-h/i==H-l/D;

辣么l=H-(H-h)*D/i;

因为数据范围不大,每个数的数据范围都是从10^-2到10^3,我们暴力枚举i即可,每一次i都加上0.001。如果这里数据比较大的话,我们需要使用三分算法。

AC代码:

#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double H,h,D;
        scanf("%lf%lf%lf",&H,&h,&D);
        double v=D*h/H;
        double compare=h;
        double output=max(v,h);
        double i=D-v;
        while(1)
        {
            i+=0.001;
            if(i>D)break;
            double l=H-(H-h)*D/i;
            //printf("%.3lf\n",l+D-i);
            output=max(l+D-i,output);
        }
        printf("%.3lf\n",output);
    }
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值