Light Bulb ZOJ - 3203

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.


Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input
3
2 1 0.5
2 0.5 3
4 3 4

Sample Output
1.000
0.750
4.000

题意:求人影子L的最长长度

思路:这其实是一道高中数学题,设影子在墙壁部分的长度为x,则在地面部分的长度为L-x,则可列方程为:

(H-h)/(D-L+x) = (h-x)/(L-x),最后可以推导出L关于x的方程,求L的最大值,(x<=0<=h),可以用高中的求导,求出极大值点

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
const double eps = 1e-8;
double H,h,D;
double f(double x){
    double upp,low;
    upp = x * x + (D - H) * x - D * h;
    low = x - H;
    return upp / low;
}
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        cin >> H >> h >> D;
        double b = -2.0 * H;
        double c = -H * D + H * H + D * h;
        double diat = b * b - 4.0 * 1.0 * c;
        if(diat <= 0){
            printf("%.3f\n",f(h));
            continue;
        }
        double x1 = (-b - sqrt(diat)) * 0.5;
        double x = max(0.0,x1);
        x = min(h,x);
        printf("%.3f\n",max(f(x),f(h)));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值