Poj 1013 Counterfeit Dollar【暴力枚举】

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 44613 Accepted: 14135

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input


ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light.

Source


题目大意:

有t组数据;

保证一共只有12个字母,每个字母代表一个钞票,钞票有可能轻,也有可能重,给你三个语句,让你输出那个假钞的信息,保证有解。


思路:


1、最不容易错的方法也就是暴力枚举。先将Even语句中的所有钞票定义为不可能是假钞,然后我们再对其他钞票(当然是在语句中出现过才行)的钞票进行以下方式枚举:

①首先将所有钞票的重量定为2

②然后枚举当前可能是假钞的钞票的重量,要么可能是1,要么可能是3(要么轻一点,要么重一点)

③然后将三个语句进行判断,如果能够保证三个语句都符合条件,那么这个钞票就是假的,那么定义出来的值如果是1当然就是假钞轻一些,反之则重一些。


2、注意不要枚举出没有在语句中出现过的字母。


Ac代码:


#include<stdio.h>
#include<string.h>
using namespace std;
char a[3][50];
char b[3][50];
char c[3][50];
int val[15];
int vis[15];
int vis2[15];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        memset(vis2,0,sizeof(vis2));
        for(int i=1; i<=12; i++)
        {
            val[i]=2;
        }
        for(int i=0; i<3; i++)
        {
            scanf("%s%s%s",a[i],b[i],c[i]);
            for(int k=0; k<strlen(a[i]); k++)
            {
                vis2[a[i][k]-'A'+1]=1;
            }
            for(int k=0; k<strlen(b[i]); k++)
            {
                vis2[b[i][k]-'A'+1]=1;
            }
            if(strcmp(c[i],"even")==0)
            {
                for(int k=0; k<strlen(a[i]); k++)
                {
                    vis[a[i][k]-'A'+1]=1;
                }
                for(int k=0; k<strlen(b[i]); k++)
                {
                    vis[b[i][k]-'A'+1]=1;
                }
            }
        }
        for(int i=1; i<=12; i++)
        {
            if(vis[i]==1)continue;
            if(vis2[i]==0)continue;
            val[i]=1;
            int flag=1;
            for(int j=0; j<3; j++)
            {
                int sum1=0;
                for(int k=0; k<strlen(a[j]); k++)
                {
                    sum1+=val[a[j][k]-'A'+1];
                }
                int sum2=0;
                for(int k=0; k<strlen(b[j]); k++)
                {
                    sum2+=val[b[j][k]-'A'+1];
                }
                if(strcmp(c[j],"even")==0)
                {
                    if(sum1!=sum2)
                    {
                        flag=0;
                    }
                }
                if(strcmp(c[j],"up")==0)
                {
                    if(sum1<=sum2)
                    {
                        flag=0;
                    }
                }
                if(strcmp(c[j],"down")==0)
                {
                    if(sum1>=sum2)
                    {
                        flag=0;
                    }
                }
            }
            if(flag==1)
            {
                if(val[i]<2)
                {
                    printf("%c is the counterfeit coin and it is light.\n",i+'A'-1);
                }
                else printf("%c is the counterfeit coin and it is heavy.\n",i+'A'-1);
            }
            val[i]=3;
            flag=1;
            for(int j=0; j<3; j++)
            {
                int sum1=0;
                for(int k=0; k<strlen(a[j]); k++)
                {
                    sum1+=val[a[j][k]-'A'+1];
                }
                int sum2=0;
                for(int k=0; k<strlen(b[j]); k++)
                {
                    sum2+=val[b[j][k]-'A'+1];
                }
                if(strcmp(c[j],"even")==0)
                {
                    if(sum1!=sum2)flag=0;
                }
                if(strcmp(c[j],"up")==0)
                {
                    if(sum1<=sum2)flag=0;
                }
                if(strcmp(c[j],"down")==0)
                {
                    if(sum1>=sum2)flag=0;
                }
            }
            if(flag==1)
            {
                if(val[i]<2)
                {
                    printf("%c is the counterfeit coin and it is light.\n",i+'A'-1);
                }
                else printf("%c is the counterfeit coin and it is heavy.\n",i+'A'-1);
            }
            val[i]=2;
        }
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值