POJ 1013 Counterfeit Dollar(枚举)

Counterfeit Dollar

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 
题目大意:有12枚硬币,其中有11枚真币和1枚假币。假币和真币的重量不同,但是并不清楚假币比真币轻还是重。现在用一架天平称了这些币3次,称的结果有up,even,down,分别表示天平右边比左边轻,两边同样重,天平右边比左边重。请找出假币并确定其与真币相比是轻是重。

解题思路:对于每一枚硬币先假设他是轻的,看这样是否符合称量结果。如果符合,问题解决。如果不符合,那么就假设他是重的。把所有硬币枚举一遍,一定能找到假币。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>


char left[3][7],right[3][7],result[3][7];

bool isFake(char ch,bool light)
{
	for(int i = 0;i < 3;i++){
		char *pLeft,*pRight;
		if(light){
			pLeft = left[i];
			pRight = right[i];
		}else{
			pLeft = right[i];
			pRight = left[i];
		}

		switch(result[i][0]){
			case 'u':
				if (!strchr(pRight,ch))
					return false;
				break;
			case 'e':
				if(strchr(pRight,ch) || strchr(pLeft,ch))
					return false;
				break;
			case 'd':
				if(!strchr(pLeft,ch))
					return false;
				break;
		}
	}
	return true;
}

int main(int argc, char const *argv[])
{
	int n;
	std::cin >> n;
	while(n--){
		for(int i = 0;i < 3;i++)
			std::cin >> left[i] >> right[i] >> result[i];
		for(char ch = 'A';ch <= 'L';++ch){
			if(isFake(ch,true)){
				std::cout << ch << " is the counterfeit coin and it is light." << std::endl;
			}
			else if (isFake(ch,false)){
				std::cout << ch << " is the counterfeit coin and it is heavy." << std::endl;
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值