hdu4618 Palindrome Sub-Array

Palindrome Sub-Array

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 941 Accepted Submission(s): 443


Problem Description
  A palindrome sequence is a sequence which is as same as its reversed order. For example, 1 2 3 2 1 is a palindrome sequence, but 1 2 3 2 2 is not. Given a 2-D array of N rows and M columns, your task is to find a maximum sub-array of P rows and P columns, of which each row and each column is a palindrome sequence.

Input
  The first line of input contains only one integer, T, the number of test cases. Following T blocks, each block describe one test case.
  There is two integers N, M (1<=N, M<=300) separated by one white space in the first line of each block, representing the size of the 2-D array.
  Then N lines follow, each line contains M integers separated by white spaces, representing the elements of the 2-D array. All the elements in the 2-D array will be larger than 0 and no more than 31415926.

Output
  For each test case, output P only, the size of the maximum sub-array that you need to find.

Sample Input
  
  
1 5 10 1 2 3 3 2 4 5 6 7 8 1 2 3 3 2 4 5 6 7 8 1 2 3 3 2 4 5 6 7 8 1 2 3 3 2 4 5 6 7 8 1 2 3 9 10 4 5 6 7 8

Sample Output
  
  
4

Source

Recommend
zhuyuanchen520
暴力都能过,无语了!……。
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
#define MAXN 350
int map[MAXN][MAXN],ans,n,m;
bool can(int ii,int jj,int len)
{
    if(ii+len-1>=n||jj+len-1>=m)
    return false;
    int i,j;
    for(i=ii;i<ii+len;i++)
    {
        for(j=0;j<len/2;j++)
        {
            if(map[i][jj+j]!=map[i][jj+len-j-1])
            return false;
        }
    }
    for(j=jj;j<jj+len;j++)
    {
        for(i=0;i<len/2;i++)
        {
            if(map[ii+i][j]!=map[ii+len-i-1][j])
            return false;
        }
    }
    ans=max(ans,len);
    return true;
}
int main()
{
   int tcase,i,j,len,maxx;
   scanf("%d",&tcase);
   while(tcase--)
   {
       scanf("%d%d",&n,&m);
       maxx=min(n,m);
       for(i=0;i<n;i++)
        for(j=0;j<m;j++)
        {
            scanf("%d",&map[i][j]);
        }
       ans=1;
      for(i=0;i<n;i++)
        for(j=0;j<m;j++)
        {
            for(len=maxx;len>ans;len--)
            {
                if(can(i,j,len))
                break;
            }
        }
    printf("%d\n",ans);
  }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值