zoj2290 Game

16 篇文章 0 订阅
Game

Time Limit: 2 Seconds Memory Limit: 65536 KB

Two players(A and B) take turns to take stones form a heap of N stones.

There are some rules:
1.A always takes first. He can take arbitrary number of stones but not all of them.
2.The number of the one who will take should less than or equal the twice of the other one taken last time. But must more than one or one.
3.The one who take take the last one stone is the winner.
4.The two players are clever enough, they can make the best choice.

Input

Every test case has only one line with one integer N(2 <= N <= 100000000), the numbers of the stones.

Output

If A will lose output "lose"

If A can win,output the numbers A should take at the first time. If there are more ways to make A win, output the smallest one.

Sample Input

4

Sample Output

#include <iostream>
#include <stdio.h>
using namespace std;
int pri[40];
int main()
{
    int n,i,ans;
    pri[0]=1,pri[1]=2;
    for(i=2;i<40;i++)
    pri[i]=pri[i-1]+pri[i-2];
    while(scanf("%d",&n)!=EOF){
        for(i=39;i>0;i--){
            if(n==pri[i])break;
        }
        if(i){printf("lose\n");continue;}
        for(ans=-1,i=39;i>=0;i--){
            if(n>=pri[i])n-=pri[i],ans=pri[i];
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值