Bomb
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)Total Submission(s): 4831 Accepted Submission(s): 1677
Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.
The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3 1 50 500
Sample Output
0 1 15HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
Author
fatboy_cw@WHU
比上一题更简单的数位dp!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define M 23
__int64 dp[M][3],pri[M];
int get(int t,int u){
if(t==2||(t==1&&u==9))return 2;
if(u==4)return 1;
return 0;
}
__int64 dfs(int pos,int t,int flag){
if(pos==0)return t==2;
if(!flag&&dp[pos][t]!=-1)return dp[pos][t];
__int64 u=flag?pri[pos]:9,ans=0;
for(__int64 i=0;i<=u;i++)
ans+=dfs(pos-1,get(t,i),flag&&i==u);
return flag?ans:dp[pos][t]=ans;
}
__int64 solve(__int64 x){
int cnt=0;
while(x){
pri[++cnt]=x%10;
x=x/10;
}
return dfs(cnt,0,1);
}
int main()
{
int tcase;
__int64 n;
memset(dp,-1,sizeof(dp));
scanf("%d",&tcase);
while(tcase--){
scanf("%I64d",&n);
printf("%I64d\n",solve(n));
}
return 0;
}