poj1753

48 篇文章 0 订阅
Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25185 Accepted: 10864

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
一个bfs搜索就可以了!
#include <iostream>
#include <queue>
 
using namespace std;
 
int step[65535];  //记录步骤
bool flag[65535];  //防止重复搜索
 
unsigned short qState[65535]; //搜索的状态,正好可以用一个16位的无符号短整形表示
int rear = 0; //队列尾指针
int top = 0; //队列头指针
 
 ///初始化:读入棋盘初始状态并把它转化为整数存入队列头,黑的位为1白的为0
void Init()
 {
     unsigned short temp = 0;
     char c;
 
     for(int i=0; i < 4; i++)
         for(int j = 0; j < 4; j++)
         {    
             cin>>c;
             if('b' == c)
                 temp |= (1<<(i*4+j));
         }
 
     qState[rear++] = temp;
     flag[temp]  = true;
 }
 
 ///翻转一个棋子并按规则对齐周围棋子附加影响
 unsigned short move(unsigned short state, int i)
 {
     unsigned short temp=0; 
     temp |= (1<<i);
     if((i+1)%4 != 0) //右,且不在最右边
         temp |= (1<<(i+1));
     if(i%4 != 0) //左,且不在最左边
         temp |= (1<<(i-1));
     if(i+4 < 16) //下
         temp |= (1<<(i+4));
     if(i-4 >= 0) //上
         temp |= (1<<(i-4));
 
     return (state ^ temp);
 }
 
 //广度优先搜索,从队列中循环取出状态,并把翻转16次(即所有情况),一旦发现满足要求的立即停止,否则加入队列
 bool BFS()
 {
     while(rear > top)
     {
         unsigned short state = qState[top++];
         //qState.pop();
         for(int i=0; i < 16; i++)
         {
             unsigned short temp;
             temp = move(state,i);
             if(0 == state || 65535 == state)
             {
                 cout<<step[state]<<endl;
                 return true;
             }
             else if(!flag[temp]) //防止重复搜索
             {
                 //qState.push(temp);
                 qState[rear++] = temp;
                 flag[temp] = true;
                 step[temp] = step[state]+1;
             }
         }
     }    
 
     return false;
 }
 
 int main(void)
 {
 
     Init();
     if(!BFS()) cout<<"Impossible"<<endl;
     
    
	 return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值