POJ1753 翻硬币题解(DFS)

在POJ的first blood,一个dfs的解法,其中有很多巧妙的解法是值得学习的。

但它头文件居然不能#include<bits/stdc++.h>,好气哦

【题目】

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 47846 Accepted: 20410

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

4*4的格子翻硬币总共有多少种翻法,这是一个值得思考的问题。

假设只翻一个,则有16种翻法;翻两个的话,就是一个16选2的组合数问题了。以此类推,可以得出,总共可能出现的结果有2^16个结果,用dfs不会爆。。。

底下到了正经题解了。

首先写一个judge函数,判断是否所有的硬币向上面花色相同。。

int judge()
{
int x = a[0][0];
for(int i=0;i<4;i++)
for(int j=0;j<4;j++)
if (x!=a[i][j]) return 0;
return 1;
}

接着是一个flip函数,主要执行翻转操作。

void flip(int x,int y)
{
a[x][y] = !a[x][y];
if(x-1>=0) a[x-1][y] = !a[x-1][y];
if(x+1<4) a[x+1][y] = !a[x+1][y];
if(y-1>=0) a[x][y-1] = !a[x][y-1];
if(y+1<4) a[x][y+1] = !a[x][y+1];
}

(刚开始的时候漏了a[x][y] = !a[x][y],wa了半天)

底下到了最最重要的dfs,,

void dfs(int x,int y,int t)
{
if(judge()==1)
{
ans = min(t,ans);
return;
}
if(x>=4||y>=4) return;
int newx = (x+1)%4;
int newy = y+(x+1)/4;
dfs(newx,newy,t);
flip(x,y);
dfs(newx,newy,t+1);
flip(x,y);
return;
}

剽窃了某位大佬的思路,自己写数据模拟可得知,当newx加满到4后会回到1,此时newy会自动+1,思路十分巧妙。

每遇到一种情况,都有翻和不翻两种选择,因此dfs两次,当翻完以后,要再flip一次翻回来,此处就是回溯的思想了。


底下是完整代码。

#include<iostream>
#include<stdio.h>
using namespace std;
const int INF = 999999;
int a[10][10],ans;
char b[5][5];
int judge()
{
int x = a[0][0];
for(int i=0;i<4;i++)
for(int j=0;j<4;j++)
if (x!=a[i][j]) return 0;
return 1;
}
void flip(int x,int y)
{
a[x][y] = !a[x][y];
if(x-1>=0) a[x-1][y] = !a[x-1][y];
if(x+1<4) a[x+1][y] = !a[x+1][y];
if(y-1>=0) a[x][y-1] = !a[x][y-1];
if(y+1<4) a[x][y+1] = !a[x][y+1];
}
void dfs(int x,int y,int t)
{
if(judge()==1)
{
ans = min(t,ans);
return;
}
if(x>=4||y>=4) return;
int newx = (x+1)%4;
int newy = y+(x+1)/4;
dfs(newx,newy,t);
flip(x,y);
dfs(newx,newy,t+1);
flip(x,y);
return;
}
int main()
{
//freopen("d://test.txt","r",stdin);
ans = INF;
for(int i=0;i<4;i++)
for(int j=0;j<4;j++)
{
cin>>b[i][j];
if(b[i][j]=='b') a[i][j] = 0;
else if(b[i][j]=='w') a[i][j] = 1;
}
dfs(0,0,0);
if(ans==INF) cout<<"Impossible";
else cout<<ans;
return 0;
}

此题大致就是这样了,希望自己能坚持下来,acm有所作为。。



  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

总想玩世不恭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值