hdu 1541 Stars

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

【题意】
给定n个点。每个点上有一个星星,问你包括点上的星星,这个点左下角一共有多少个星星,统计出有星星数量分别为1~n的点各是多少个。其中一个重要条件是:给定点的纵坐标是严格不下降的。

【分析】
因为给定点的纵坐标不下降,所以只用考虑横坐标就行了,显然对于每个点来说都是统计之前的点中横坐标比他小的有多少个,显然是一个求和问题,这里可以用线段树来做,但是树状数组也可以实现而且更简单,所以我们用树状数组来实现。
其实主要就是模板问题了,但是这里我们取个巧,因为每个点都至少有一个自己的星星,所以我们索性直接将这个都剪掉,然后输出的时候错一位就行。

【代码】

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxm=32005;
int a[maxm];
int c[maxm];
int n,x,y;
void add(int x) {
    while(x<=maxm) {
        c[x]++;
        x+=x&(-x);
    }
}
int sum(int x) {
    int ans=0;
    while(x>0) {
        ans+=c[x];
        x-=x&(-x);
    }
    return ans;
}
int main() {
    freopen("in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF) {
        memset(c,0,sizeof(c));
        memset(a,0,sizeof(a));
        for(int i=0; i<n; i++) {
            scanf("%d%d",&x,&y);
            a[sum(x+1)]++;
            add(x+1);
        }
        for(int i=0; i<n; i++)
            printf("%d\n",a[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值