POJ-2352 Stars (树状数组+思维)

带你到北大POJ数星星

Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 59074 Accepted: 25182

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

这道题看着挺吓人的,昨天测试的时候出题率也不是很高,而且比较急促,我居然连题都没读懂,两脸懵逼。。。

到了今天早上补题的时候终于又仔细的看了一遍,发现这道题是如此的简单   woc。。。亏死了。。。当然这道题的坑点也不少

先说一下题意,就是在坐标系中,每个星星都有自己的坐标,要根据他的坐标以及其他星星的位置来确定星星的等级。 

我自己的个人理解就是  以这个点画一个十字,他的下方、左侧以及左下方区域其他星星的个数就是他的等级。

那么这道题应该怎么去整呢?其实他给的坐标是有规律的,他已经将纵坐标按照升序给你排好了,这就证明了纵坐标变成了一个赤裸裸的摆设,也就是说只要是后面的星星的横坐标不小于前面的,那么实锤了,前面的肯定是和后面星星的小弟,综上所述,要求每一个星星的等级,只需要判断一下他的前面出现过几个横坐标比他小的就ojbk了。那么怎么去判断呢?枚举吗?祝你TLE,肯定不是的了,他让你输出每个等级   星星的个数,我们只需要一个数组  LEV【】来存每个等级的个数就可以了,当然个数的输入还是用树状数组比较简单。

提到树状数组,本道题最大的坑点来了,就是树状数组的求和范围只能是  1~pos,并没有0啊,那么0等级的怎么储存呢?我们就将坐标往后延伸一下就ok了,这一点没注意到你就会不断地  TLE  TLE  TLE  

look at the code:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int mm=32005;

int c[mm];
int n;
int lev[mm];

int lbt(int x){
	return x&-x;
}

void up(int pos){
	while(pos<=mm){//注意这里的上限  
		c[pos]++;
		pos+=lbt(pos);
	}
}

int sum(int pos){
	int res=0;
	while(pos>0){
		res+=c[pos];
		pos-=lbt(pos);
	}
	return res;
}

int main()
{
	scanf("%d",&n);
	int x,y;
	for(int i=1;i<=n;i++){
		scanf("%d%d",&x,&y);
		x++;//!!!没有sum(0)  只能往后延伸 
		lev[sum(x)]++;//前面的x比当前x小的个数  即为当前的等级 
		up(x);// 当前的加进来  
	}
	for(int i=0;i<n;i++){
		printf("%d\n",lev[i]);
	} 
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值