【openjudge】Charm Bracelet

总时间限制: 1000ms 内存限制: 65536kB
描述
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a ‘desirability’ factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入
Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
输出
Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
样例输入
4 6
1 4
2 6
3 12
2 7
样例输出
23

题解:
没怎么做过背包问题的我。。。第一想法就是用了错误的贪心算法,按单位体积价值排序先选大的。
错误案例:
如果有 2 个物品, 背包体积为9.
第一个物品体积为 1 价值为 1
第二个物品体积为 9 价值为 2
如果按照这种贪心策略,那么第一件物品肯定是排在前面了,
而选了第一件物品就不能选第二种物品。
那么最后的结果就是 1 而正确结果应该是 2

应该要使用动态规划

AC代码:

#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
int weight[35000],desire[35000],dp[35000];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&weight[i],&desire[i]);
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=w[i];j--)
            {                                                                    
                dp[j]=max(dp[j],dp[j-weight[i]]+desire[i]);
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值