HDU 3400 Line belt (两次三分解凹凸函数)

Line belt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2775    Accepted Submission(s): 1058


Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww's speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?
 

Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10
 

Output
The minimum time to travel from A to D, round to two decimals.
 

Sample Input
  
  
1 0 0 0 100 100 0 100 100 2 2 1
 

Sample Output
  
  
136.60
 

Author
lxhgww&&momodi
 

Source
 

Recommend
lcy
 

# include <iostream>
# include <cmath>
# include <fstream>
using namespace std;
const double eps = 1e-6;
struct point{
    double x,y;
};
point a,b,c,d;
double v1,v2,v3;
point calmid(point a,point b){
    point mid;
    mid.x = (a.x+b.x)/2;
    mid.y = (a.y+b.y)/2;
    return mid;
}
double dis(point a,point b){
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double sf2(point m){
    point mid,midmid,left,right;
    left = c,right = d;
    double dis1=0,dis2 = 100;
    while(fabs(dis1-dis2)>eps){
        mid = calmid(left,right);
        midmid = calmid(mid,right);
        dis1 = dis(m,mid)/v3+dis(mid,d)/v2;
        dis2 = dis(m,midmid)/v3+dis(midmid,d)/v2;
        if(dis2>dis1) right = midmid;
        else left = mid;
    }
    return dis1;
}
double sf(){
    point mid,midmid,left,right;
    left = a,right = b;
    double dis1=0,dis2=100;
    while(fabs(dis1-dis2)>eps){
        mid = calmid(left,right);
        midmid = calmid(mid,right);
        dis1 = dis(mid,a)/v1 + sf2(mid);
        dis2 = dis(midmid,a)/v1 + sf2(midmid);
        if(dis2>dis1) right = midmid;
        else left = mid;
    }
    return dis1;
       
}
int main()
{
    //ifstream cin("1.txt");
    cout.precision(2);
    int T;
    while(cin>>T){
        while(T--){
            cin>>a.x>>a.y>>b.x>>b.y>>c.x>>c.y>>d.x>>d.y>>v1>>v2>>v3;
            //cout<<a.x<<"  "<<a.y<<"  "<<b.x<<"  "<<int(b.y)<<"  "<<v1<<"  "<<v2<<"  "<<v3<<endl;
            cout<<fixed<<sf()<<endl;
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值