HDU 5289_Assignment

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

题意是给出一个数组,求区间的个数,每个区间里的最大值和最小值的差值要小于K,区间长度不限

这道题主要是用两个优先列队来做,用两个优先列队来维护区间的最大值和最小值,然后每次把数组的中数据放进去都要判断一次最大值和最小值,符合题意的就加上,不符合题意的就删掉,其中用multiset可以删除指定元素。(嘛~都是听学长给我讲的,这种用法现在还是挺陌生的,得去看看有关STL的书才行)


#include<iostream>
#include<set>
#include<queue>
using namespace std;
int num[100010];
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,k;
		cin>>n>>k;
		for(int i=0;i<n;i++) cin>>num[i];
		multiset<pair<int,int> > q1,q2;
		long long ans=0;
		int nut=0;
		for(int i=0;i<n;i++)
		{
			q1.insert(make_pair(num[i],i));
			q2.insert(make_pair(-num[i],i));
			while(-(*q1.begin()).first-(*q2.begin()).first>=k)
			{
				q1.erase(make_pair(num[nut],nut));
				q2.erase(make_pair(-num[nut],nut));
				nut++;
			}
			ans+=i-nut+1;
		}
		cout<<ans<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值