HDU 2594 Simpsons’ Hidden Talents(kmp)

Time Limit:1000MS Memory Limit:32768KB

Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: “abab”

The prefixes are: “a”, “ab”, “aba”, “abab”
For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input
1
4
abab

Sample Output
6

题意: 找出这个字符串的所有前缀出现次数的总和。

思路: 说句实话,我是没想到next数组还能这样用,这个数组真够灵活的,那就是在把next数组求出来之后,不断回溯,每次找到子串中的前缀就给结果加一,然后就出来了,最后别忘了取模就是了,具体的,可以自己写个例子模拟下,比如aaaaaa,或者abcabcabcabc,嗯,这两个挺典型的。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#include<map>
#include<stack>
#include<set>
#define ll long long
#define maxn 100010
#define PI acos(-1.0)    //圆周率
const int mod=1e4+7;
using namespace std;
int ans[2*maxn];
char str[2*maxn];
int f[2*maxn];
int T,n;
void makenext(char *a)
{
    memset(f,0,sizeof(f));

    int i=0;
    int j=-1;
    f[0]=-1;
    while(i<n)
    {
        if(j==-1||a[i]==a[j])
        {
            i++;
            j++;
            f[i]=j;
        }
        else  j=f[j];
    }

  //  for(int i=0;i<n;i++)  cout<<f[i]<<" ";  cout<<endl;
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        scanf("%s",str);

        makenext(str);

        int ans=n;            //初始化为字符串的长度
        for(int i=1;i<=n;i++)
        {
            int k=f[i];
            while(k)
            {
                ans=(ans+1)%mod;     //找到一个子串中的前缀就加一
                k=f[k];
            }
        }

        printf("%d\n",ans);
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值