poj 3278 Catch That Cow bfs

链接:http://poj.org/problem?id=3278

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 78862 Accepted: 24869

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

题意:从n到k,每一步可以+1,-1,*2,求到k的最短步数

思路:最短路问题,bfs,基础题,与石油大学的“奇怪的电梯”异曲同工

注意:

1.小剪枝,数组不能越界不然re

2.n>=k,只能不停-1

代码:

#define _CRT_SBCURE_MO_DEPRECATE    
#include<iostream>    
#include<stdlib.h>    
#include<stdio.h>    
#include<cmath>    
#include<algorithm>    
#include<string>      
#include<string.h>    
#include<set>    
#include<queue>    
#include<stack>    
#include<functional>     
using namespace std;
const int maxn = 100000 + 10;
const int INF = 0x3f3f3f3f;

struct node {
	int x;
	int t;
};

int n, k;
int vis[maxn];

int bfs(int s) {
	memset(vis, 0, sizeof(vis));
	queue<node>Q;
	node a;
	a.x = s;
	a.t = 0;
	Q.push(a);
	while (!Q.empty()) {
		node now = Q.front();
		Q.pop();
		vis[now.x] = 1;
		if (now.x == k)return now.t;
		node next;
		for (int i = 0; i < 3; i++) {
			if (i == 0) {//后退一格
				if (now.x - 1 > 0 && !vis[now.x - 1] && now.x - 1 <= maxn) {
					next.x = now.x - 1;
					next.t = now.t + 1;
					vis[next.x] = 1;
					Q.push(next);
				}
			}
			if (i == 1) {//前进一格
				if (now.x + 1 <= maxn && !vis[now.x + 1]) {
					next.x = now.x + 1;
					next.t = now.t + 1;
					vis[next.x] = 1;
					Q.push(next);
				}
			}
			if (i == 2) {
				if (now.x * 2 <= maxn && !vis[now.x*2]) {
					next.x = now.x*2;
					next.t = now.t + 1;
					vis[next.x] = 1;
					Q.push(next);
				}
			}
		}
	}
}

int main()
{
	while (scanf("%d %d", &n, &k) != EOF && n != -1 && k != -1) {
		if (n >= k) printf("%d", n - k);
		else printf("%d\n", bfs(n));
	}
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值