POJ - 2420 A Star not a Tree? 三分套三分 或 模拟退火

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub.

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

题解:经过分析,发现若x固定的情况下,存在二次函数性质,所以我们可以三分套三分来解决

第二种,他是一个寻找最优解的情况,因此也可用模拟退火来解决

三分套三分:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
#define eps 1e-8
struct node{
	double x,y;
}a[110];
int n;
double judge_(double x,double y)
{
	double ans=0;
	for(int i=1;i<=n;i++)
		ans+=sqrt((x-a[i].x)*(x-a[i].x)+(y-a[i].y)*(y-a[i].y));
	return ans;
} 
double judge(double x)
{
	double l=0,r=10000;
	double ans;
	while((r-l)>eps)
	{
		double m1=l+(r-l)/3;
		double m2=r-(r-l)/3;
		double s1=judge_(x,m1);
		double s2=judge_(x,m2); 
		if(s1<s2)
			r=m2,ans=s1;
		else
			l=m1,ans=s2;
	}
	return ans;
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)scanf("%lf%lf",&a[i].x,&a[i].y);
		double l=0,r=10000;
		double ans;
		while((r-l)>eps)
		{
			double m1=l+(r-l)/3;
			double m2=r-(r-l)/3;
			double s1=judge(m1);
			double s2=judge(m2); 
			if(s1<s2)
				r=m2,ans=s1;
			else
				l=m1,ans=s2;
		}
		printf("%.0f\n",(ans));
	}
	return 0;
} 

模拟退火:

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
#define eps 1e-10
struct node{
	double x,y;
}a[110];
int n;
double judge_(double x,double y)
{
	double ans=0;
	for(int i=1;i<=n;i++)
		ans+=sqrt((x-a[i].x)*(x-a[i].x)+(y-a[i].y)*(y-a[i].y));
	return ans;
}
int fx[5]={0,0,1,-1};
int fy[5]={1,-1,0,0};
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)scanf("%lf%lf",&a[i].x,&a[i].y);
		double l=0,r=10000;
		double ans,x=0,y=0,t=1,xx,yy;
		while(t>eps)
		{
			ans=judge_(x,y);
			int i;
			for(i=0;i<4;i++)
			{
				xx=x+t*fx[i];
				yy=y+t*fy[i];
				if(judge_(xx,yy)+eps<ans)
					break;
			}
			if(i!=4)
				x=xx,y=yy;
			else
				t*=0.88;
		}
		printf("%.0f\n",(ans));
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值