HDU - 4221 Greedy? 贪心

iSea is going to be CRAZY! Recently, he was assigned a lot of works to do, so many that you can't imagine. Each task costs Ci time as least, and the worst news is, he must do this work no later than time Di!
OMG, how could it be conceivable! After simple estimation, he discovers a fact that if a work is finished after Di, says Ti, he will get a penalty Ti - Di. Though it may be impossible for him to finish every task before its deadline, he wants the maximum penalty of all the tasks to be as small as possible. He can finish those tasks at any order, and once a task begins, it can't be interrupted. All tasks should begin at integral times, and time begins from 0.

Input

The first line contains a single integer T, indicating the number of test cases.
Each test case includes an integer N. Then N lines following, each line contains two integers Ci and Di.

Technical Specification
1. 1 <= T <= 100
2. 1 <= N <= 100 000
3. 1 <= Ci, Di <= 1 000 000 000

Output

For each test case, output the case number first, then the smallest maximum penalty.

Sample Input

2
2
3 4
2 2
4
3 6
2 7
4 5
3 9

Sample Output

Case 1: 1
Case 2: 3

题意:给出每个任务至少要操作的时间和最晚截止时间,若在t时间完成,t>d,则惩罚为t-d,求所有的惩罚的最大值最小是多少

题解:最后完成所有任务的时间是确定的,要让每个任务的惩罚尽可能小,当然要先做截止时间靠前的,因为若放在后面,完成的时间越靠后,惩罚越大,这样最大值会更大,按截止时间排序,记录下当前时间即可

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=110000;
typedef long long ll;
struct node{
	ll x;
	ll end;
}a[N];
bool cmp(node xx,node yy)
{
	return xx.end<yy.end;
}
int main()
{
	int T,nn=1;
	int n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)scanf("%lld%lld",&a[i].x,&a[i].end);
		ll tm=0;
		sort(a+1,a+1+n,cmp);
		ll ans=0;
		for(int i=1;i<=n;i++)
		{
			tm+=a[i].x;
			if(tm>a[i].end)
			{
				ans=max(ans,tm-a[i].end);
			}
		}
		printf("Case %d: %lld\n",nn++,ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值