Georgia and Bob
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 7457 | Accepted: 2254 |
Description
Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:
Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.
Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.
Given the initial positions of the n chessmen, can you predict who will finally win the game?
Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.
Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.
Given the initial positions of the n chessmen, can you predict who will finally win the game?
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.
Output
For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.
Sample Input
2 3 1 2 3 8 1 5 6 7 9 12 14 17
Sample Output
Bob will win Georgia will win
题意:有一个线性的网格,每个格子只能放一枚棋子,然后给你N个棋子的位置。两人轮流操作,每次只能将棋子向右移动任意步数,但是不能越过前面的棋子。问最后不能移动者算输。
题解:传说中的阶梯博弈。将棋子位置从小到大排序,从最后取,将两两合并为1个棋子,两两棋子之间的距离进行nim博弈异或。等于0则先手必输。理解下,如果移动两者棋子中前者,则后者可依葫芦画瓢移动相应步数,so后者移动才是关键.后者移动技巧参考nim博弈。
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
int a[10010],T,n,i;
int main()
{
scanf("%d",&T);
while (T--)
{
a[0]=0;
scanf("%d",&n);
for (i=1;i<=n;i++)
scanf("%d",&a[i]);
sort(a+1,a+n+1);
int ans=0;
for (i=n;i>0;i-=2)
ans^=(a[i]-a[i-1]-1);
if (!ans) printf("Bob will win\n");
else printf("Georgia will win\n");
}
return 0;
}