poj 1704 Georgia and Bob (阶梯博弈)

Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9706 Accepted: 3189

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source

[Submit]   [Go Back]   [Status]   [Discuss]



题解:阶梯博弈。

阶梯博弈的模型: 博弈在一列阶梯上进行...每个阶梯上放着自然数个点..两个人进行阶梯博弈...每一步则是将一个集体上的若干个点( >=1 )移到前面去..最后没有点可以移动的人输..

有个介绍阶梯博弈的博客:http://blog.csdn.net/kk303/article/details/6692506

对于阶梯博弈其实就是将奇数位上的点进行nim游戏。异或和为0,则为必败态。

这道题可以将每两个球之间的空格看做要移动的点,然后每次的移动相当于将空格向后移动,也就等价于阶梯博弈中的将每个位置的点向下一级移动任意个。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 2003
using namespace std;
int m,n;
int a[N],p[N],b[N];
int main()
{
	freopen("a.in","r",stdin);
	scanf("%d",&m);
	for (int i=1;i<=m;i++) {
		scanf("%d",&n); int ans=0;
		int cnt=0;
		for (int j=1;j<=n;j++) scanf("%d",&a[j]);
		sort(a+1,a+n+1);
		for (int j=2;j<=n;j++) p[j]=a[j]-a[j-1]-1;
		p[1]=a[1]-1;
		for (int j=1;j<=n;j++) b[j]=p[n-j+1];
		for (int j=1;j<=n;j++){
			if (!b[j]) cnt++;
			if (j&1) ans^=b[j];
			//cout<<b[j]<<" ";
		}
		//cout<<endl;
		if (cnt==n) {
			printf("Bob will win\n");
			continue;
		}
		if (ans) printf("Georgia will win\n");
		else printf("Bob will win\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值