PAT甲级 1106. Lowest Price in Supply Chain (25)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers.It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2


题目大意

供应商只有一个(对应树的根),只有零售商能直接面对顾客(对应树的叶子),经销商就是在供应商和零售商之间的商家(对应树的非叶、非根结点)。

一个商家只有一个提供商品的商家(除根外),并且没有商品循环。(原文中的这句话没什么用,说明了是一棵树)。

输入n个商家(供应商或零售商或经销商),和初始价格p,以及每经过一层的增长率r(比上一级增长了r%)。

接下来输入n各商家的信息,k表示有k个商家从当前商家处进货,k=0表示是零售商。

问你顾客能得到的最低价格,以及按最低价格卖出商品的零售商(k=0的)。

样例解析:(0)是供应商,(4、7、9、8)是零售商,每经过一级商品价格变为price*(1+r%)。

因此要求的零售商就是4,和7,商品价格就是p*(1+r%)*(1+r%)。

解题思路

输入的信息:“提供商品的商家”和“接受该商家商品的商家”之间建边,深搜求每个结点的深度,求出最小深度的叶子节点深度及数量就可以了。

#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cstdlib>
#include <climits>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

#define ll long long
const int MAXN = 100000 + 5;
const int MAXM = 100000 + 5;
const int INF = 0x7f7f7f7f;
template <class XSD> inline XSD f_min(XSD a, XSD b) { if (a > b) a = b; return a; }
template <class XSD> inline XSD f_max(XSD a, XSD b) { if (a < b) a = b; return a; }
int n, m;
double p, r;
vector<int>mp[MAXN];
bool vis[MAXN], check[MAXN];
int deep[MAXN];
void Dfs(int root, int dee){
    deep[root] = dee;
    for(int i=0; i<mp[root].size(); i++){
        Dfs(mp[root][i], dee+1);
    }
}
void Getdata(){
    int k;
    memset(deep, 0, sizeof deep);
    memset(vis, false, sizeof vis);
    memset(check, false, sizeof check);
    for(int i=0; i<n; i++){
        scanf("%d", &k);
        if(!k) vis[i]=true;///零售商
        else{
            int x;
            for(int j=0; j<k; j++){
                scanf("%d", &x);
                check[x] = true;
                mp[i].push_back(x);
            }
        }
    }
}
void Solve(){
    int root;
    for(int i=0; i<n; i++) if(!check[i]){root=i;break;}
    Dfs(root, 0);
    int times=INF;
    for(int i=0; i<n; i++) if(vis[i]) times=f_min(times, deep[i]);
    int cnt=0;
    double rate=1.0+r/100.0;
    for(int i=0; i<times; i++) p*=rate;
    for(int i=0; i<n; i++) if(vis[i]&&deep[i]==times) cnt++;
    printf("%.4f %d\n", p, cnt);
}
int main(){
    while(~scanf("%d%lf%lf", &n, &p, &r)){
        Getdata();
        Solve();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值