POJ1922浅析------Ride to School

Ride to School
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 16011 Accepted: 6439

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

Vi [TAB] Ti

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20	0
25	-155
27	190
30	240
2
21	0
22	34
0

Sample Output

780
771

Source

Beijing 2004 Preliminary@POJ

 

 

 

题目类型:简单计算

 

题目大意:

        Charley每天要行北大的万柳校区到主校区“燕园”,总路程4.5km。他喜欢和人结伴而行。如果有人比他早出发,则他等下一个人与他结伴。如果路途中从后面来的rider比自己快,则他放弃原来的伙伴,与这个快的rider结伴而行,直到到达主校区。Charley的出发时间记为。

        已知各rider出发时间,和速度(kilometers per hour)。

 

题目浅析:其实就是找出所给样例中最早到达的人。当然,比Charley早出发的人除外。

 

注意:处理输出结果时小数部分四舍五入。

 

我的代码如下:

#include<stdio.h>
int main()
{
    int n,q,w,p;
    double l,min;
    while(scanf("%d",&n),n) 
    {
        min=344443443.0;
        while(n--)
        {
            scanf("%d%d",&q,&w);
            if(w)
            {
                l=w*1.00+4.5*3600*1.0/q;
                if(l<min) 
                    min=l;
            }
        }
        p=min;
        if(min-p!=0)
            printf("%.f\n",min+0.5);
        else 
            printf("%d\n",p);
    }
    return 0;
}


 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值