Gold Coins
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 17568 | Accepted: 10963 |
Description
The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.
Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).
Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).
Input
The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.
Output
There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.
Sample Input
10 6 7 11 15 16 100 10000 1000 21 22 0
Sample Output
10 30 6 14 7 18 11 35 15 55 16 61 100 945 10000 942820 1000 29820 21 91 22 98
Source
题目类型:简单计算
题目大意:
一组数列:A:1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6 ……n n n n ……n n n(共计n个n)
数列Ai中 i 表示天数,要求输入 i ,输出 A1+A2+……+Ai的值S;
题目浅析:
显然,根据数列中项与值的关系,可以把 i 模拟为自然数前n项和,Ai 模拟为自然数前n项平方和。建数组B、C存放。
在 B 中找到输入 n 所对应的 i 值,输出 对应的 C 值。
注意:
在B中查找时不一定能找到确切的 Bi 与n相等,但可以确定 i 值。然后 根据 B 和 Ci 的关系,算出具体的S值。
我的代码如下:
#include<stdio.h>
int main()
{
long i,n,day;
long a[200],b[200];
for(i=1;i<=150;i++)
{
a[i]=i*(i+1)*(2*i+1)/6;
b[i]=i*(i+1)/2;
}
while(scanf("%ld",&n),n)
{
day=0;
for(i=1;i<=149;i++)
{
if(b[i]==n)
day=a[i];
else if(n>b[i]&&n<b[i+1])
day=a[i]+(i+1)*(n-b[i]);
if(day)
break;
}
printf("%ld %ld\n",n,day);
}
return 0;
}