Subsequence
Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input 2 10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5 Sample Output 2 3 Source |
原来这种做法叫尺取法,印象中用过好多次了原来还有个这样高大上的名字~
题意是给你一个正数序列,问你最短的连续子序列长度l使得这段子序列的和大于等于S。
先找到一个大于等于S的从1开始的子序列,然后不断地减掉左边的,加上右边的,每次贪心,取最小值。
#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cstdio>
using namespace std;
typedef unsigned long long ull;
#define maxn 111111
int n;
long long a[maxn], m;
int main () {
int t;
scanf ("%d", &t);
while (t--) {
scanf ("%d%lld", &n, &m);
for (int i = 1; i <= n; i++) {
scanf ("%lld", &a[i]);
}
long long sum = 0;
int l = 1, r = 1;
while (sum < m && r <= n) {
sum += a[r++];
}
if (sum < m) {
printf ("0\n");
continue;
}
int ans = n;
for (r = r; r <= n+1; r++) {
while (sum-a[l] >= m) {
sum -= a[l++];
}
ans = min (ans, r-l);
if (r == n+1)
break;
sum += a[r];
}
printf ("%d\n", ans);
}
return 0;
}